X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop the browser from defaulting to swagbuck.com for my searching?

Posted

I have removed the addons, uninstalled from my computer and did a computer restart. Swagbuck is taking over Firefox and I cannot stand it - I love using Firefox but if I can't remove this swagbuck issue I'm going to switch to another browser. I've searched and searched and it seems there are no clear answers how to remove this program. I'd definitely classify this as malware since there are no options to remove it. Can someone PLEASE tell me how to remove this???

I've been through my add-ons and extensions, nothing has worked and if I use a blocking add-on (to block swagbuck.com) I cannot use Firefox at all because every search comes up as "blocked".

Modified by melinda2538

Chosen solution

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the orange Firefox button and go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

Read this answer in context 10

Additional System Details

This happened

Every time Firefox opened

This started when...

I clicked a link on a couponing blog

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

I've been through my add-ons and extensions, nothing has worked and if I use a blocking add-on (to block swagbuck.com) I cannot use Firefox at all because every search comes up as "blocked".

Xircal 334 solutions 3835 answers

Chosen Solution

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the orange Firefox button and go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

Helpful Reply

YOU ARE AWESOME!!! Thank you so very much for your help!

Xircal 334 solutions 3835 answers

You're welcome.

Could you please click the "Solved It" button next to the post which solved the problem for you? This will help others searching for a solution to the same question.

Thanks.