X
Tap here to go to the mobile version of the site.

Support Forum

firefox requires 10.5. My mac is osx 10.5.8. Why can't I use the new firefox?

Posted

The latest firefox requires osx 10.5. My mac is 10.5.8 but the latest firefox will not run on my mac. I am allowed to download it but it will not function after I download it. With my present firefox I am denied many functions on various sites, particularly on youtube.

The latest firefox requires osx 10.5. My mac is 10.5.8 but the latest firefox will not run on my mac. I am allowed to download it but it will not function after I download it. With my present firefox I am denied many functions on various sites, particularly on youtube.

Additional System Details

This happened

Every time Firefox opened

This started when...

this week

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Test Your JVM.
  • Netscape Navigator Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r102
  • Verified Download Plugin
  • Macromedia Shockwave for Director Netscape plug-in, version 10.1.1
  • Shockwave Flash 6.0 r47

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5433 solutions 40564 answers

http://www.mozilla.com/en-US/firefox/4.0/system-requirements/

Mac Operating Systems

  • Mac OS X 10.5
  • Mac OS X 10.6

Recommended Hardware

  • Macintosh computer with an Intel x86 processor
  • 512 MB of RAM
  • 200 MB hard drive space
http://www.mozilla.com/en-US/firefox/4.0/system-requirements/ Mac Operating Systems * Mac OS X 10.5 * Mac OS X 10.6 Recommended Hardware * Macintosh computer with an '''Intel x86 processor''' * 512 MB of RAM * 200 MB hard drive space