X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When I hold Ctrl with a link to open, it opens in a new window. Before I upgraded FF these links opend in the same window on a new tab. How do I get that feature back?

Posted

I need to open many links and tabs for work, it is very frustrating th have to keep going back and forth through many windows. I was able to simply open new links on my current window in new tabs. How do I set this up in the new version of FF?

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • 1.9.0009.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • iTunes Detector Plug-in
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • 6.0.12.1483
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Google Update
  • Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

See Tabs Panel

Question owner

I have viewed this and selected "open new window in a new tab instead", and still the links open in new windows.

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97019 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")