Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lock-down search settings against attenpted changes?

  • 4 replies
  • 33 have this problem
  • 1531 views
  • Last reply by LvsW

more options

I noticed that my search bar was changed to Yahoo instead of Google, and reset it. Also had entered a couple of sho.rt/urls and came upon a redirect to search.yahoo.com.

A few days ago I installed a freeware that loaded a program into my Windows XP startup to change my MSIE home page or search preferences to Yahoo from Live, and IE alerted me and I blocked the change. Then to get rid of the bootup notice that a program has attempted to change things and was blocked, I ran Spybot Search & Destroy and removed the offender from the start sequence.

There are Microsoft and third-party ways to lock-down MSIE, and I am looking for a way to do this in Firefox.4.

Addendum: DOWNLOADED IOBit SMART DEFRAG 2 and it loaded that starter to change MSIE settings, and gave Firefox two new toolbars: IOBit Toolbar 4.4 and Widgi Toolbae Platform 4.4. They will be disabled as soon as I send this. And I will toss IOBit Smart Defrag too. I discovered all of this when I pasted troubleshoot info below.

Chosen solution

Install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/


To revert to Google as your preferred search engine, please do the following.


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=


The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.


  • Go to the site you want to set as your homepage.
  • Click the orange Firefox button and go to Options | Options | General
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.
Read this answer in context 👍 10

All Replies (4)

more options

Chosen Solution

Install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/


To revert to Google as your preferred search engine, please do the following.


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=


The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.


  • Go to the site you want to set as your homepage.
  • Click the orange Firefox button and go to Options | Options | General
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.
more options

Thank you! I disabled the toolbar and toolbar platform, closed Firefox and removed the toolbar and defrag tool, but didn't see the toolbar platform.

I restarted Firefox and checked my add-ons and both toolbar and platform were gone.

Installed the new add-on and performed the keyword.url search, found the default to be an empty string.

My home pages weren't touched, fortunately. (By the way, for what it's worth, my MSIE is live.com only because I just reinstalled Windows recently, and only used IE to get Firefox and do Windows Updates!)

I hope my question and your answer will be a help to many! Thank you!

more options

You're welcome.

Could you please click the "Solved It" button? This will help others searching for a solution to the same question.

Thanks.

more options

Thank! I didn't see that Solved It button off right of your answer until after I was signed in and looked again! (I have to scroll right, then, to see it.)