Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 - Why is my site displaying incorrectly with hardware acceleration enabled ??

  • 6 replies
  • 7 have this problem
  • 1 view
  • Last reply by cor-el

more options

More specifically it's Direct2D, disabling hardware acceleration or changing "gfx.direct2d.disabled = true" in about:config fixes everything. The hardware acceleration is causing my site to display things like tables and line breaks incorrectly, and this is not happening in other browsers. I don't know how to write in HTML or any other kind of web page script, I used a program to make my pages and they worked fine in FF until this new version. An example is my popular N64 emulation tutorial, view it with acceleration enabled, then view it disabled and u will see what I mean. Firefox mangles the text, tables, and lines between sections.

http://bmgcl.emuxhaven.net/tutorials/N64Tutorial.htm

A warning to anyone who visits my site or reads my tutorials to disable acceleration or edit the about:config is not an acceptable solution, browsers should not need additional configuration beyond default to view web content. I have noticed errors on other sites as well with hardware acceleration enabled, and again this is not happening with other browsers, just this new version of Firefox.

So what can I do about this? I've been researching for hours and found no real fix, which is why I am here (and slightly frustrated). Can I expect an update in the future that corrects this, or am I going to have to put a warning label on my pages that says "Does not display correctly in Firefox v4+"?

All Replies (6)

more options

Bump. Even if I have to manually edit my pages code I am willing to do that as well, I just need to know the solution! If someone would be kind enough to take a look at the code generated by Web Page Maker on the page in my previous post and offer any suggestions I'd be grateful.

Modified by Bighead

more options

BUMP. Would really like a reply that at least explains what is going... or what I need to do different in my HTML... I'm not completely oblivious to it, I can modify my code if only someone would tell me why this glitch is happening.

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).


Hardware acceleration shouldn't cause that to happen. It usually indicates a problem with the graphics display driver or a problem with a specific font.

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.


Try to toggle some of the Boolean gfx (font) prefs on the about:config page to enable or disable some features.
Filter: gfx

more options

The problem may be with nvidia cards and drivers, but I'm not entirely sure since I don't know anyone with a Radeon card to view the site on. I have updated my graphics card drivers to the latest revision 270.61, and the problem still persists. I tried four different systems, unfortunately all nvidia based, and the errors display with Geforce 8600, GTX260, GTX460, and GTX560; all had different driver revisions.

I also tried the latest versions of Internet Explorer and Google Chrome with hardware acceleration enabled and the pages display correctly on both. It's a shame that only my favorite browser is having this problem, I don't understand how graphics card drivers could be the issue unless they handle all browsers differently.

Here are the screenshots of the error. Comparisons of D2D enabled and without:

Main Page - With - Without

My Tutorial - With - Without

Don't mind the news item, I was getting a little impatient :P. But as you can see tables and the line breaks are being merged together with D2D enabled, and fonts are overlapping in some places or being cut off. The font size I use is 11, but I think Firefox is rendering it as if it were size 12 or the line spacing is a bit off. If you compare the two images, the font is slightly larger and lines are spaced further apart with D2D enabled.

It probably is an issue with the font. The font I am using is Calibri - size 11 for all my pages; perhaps Firefox has issues with this font. I have not tried a different one yet, but I am willing to change my font or the size if it fixes the issue. I'll try something simple like Arial and adjust the font size and post my results.

Modified by Bighead

more options

I can verify the problem is when fonts are larger than size 10. Anything below displays correctly, anything above and the font size always appears to be set one size higher. So now that the problem has been identified, the big question is: where is the source of this problem? Should I hope for a graphics card driver update or a firefox update to correct this issue? I really don't want to go back and redo everything in a smaller font if I don't have to, not because of the effort involved but because size 10 is kinda small.

Modified by Bighead

more options

Are you using default font settings or did you make changes?

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)
  • Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

You can use one of these extensions to set a default font size and page zoom on web pages: