X
Tap here to go to the mobile version of the site.

Support Forum

In the new FF, typing a word in address bar doesn't perform a google search anymore

Posted

I have just installed the new FF (which actally looks a lot like Explorere). I used to be able to type a word into the address bar eg: Facebook, and I would either be redirected immediately to Facebook otherwise FF would perform a google search. Has this feature been eliminated or is there a setting that can do this.

BTW, I do not like the new FF. The previous version was much more user friendly and visually pleasing.

I have just installed the new FF (which actally looks a lot like Explorere). I used to be able to type a word into the address bar eg: Facebook, and I would either be redirected immediately to Facebook otherwise FF would perform a google search. Has this feature been eliminated or is there a setting that can do this. BTW, I do not like the new FF. The previous version was much more user friendly and visually pleasing.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.2 r153
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • iTunes Detector Plug-in
  • 4.0.60129.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_16 for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

TonyE
  • Moderator
1034 solutions 8840 answers

Helpful Reply

The change between Firefox 3.6.* and Firefox 4 is how location bar search works. In Firefox 3.6 it uses Google "Browse by name" search. With the browse by name search, it performs a Google search and if there is a clear match it will take you to the site, otherwise it shows the Google search result. With Firefox 4 it just performs a Google search if you type something which is not recognised as a URL.

To get the Firefox 3.6 behaviour on Firefox 4 you need to change a hidden preference.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference keyword.URL, double-click on it and change its value to the link shown below

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

If you prefer, you can also do this by installing the Browse by Name extension - https://addons.mozilla.org/firefox/addon/browse-by-name

The change between Firefox 3.6.* and Firefox 4 is how location bar search works. In Firefox 3.6 it uses Google "Browse by name" search. With the browse by name search, it performs a Google search and if there is a clear match it will take you to the site, otherwise it shows the Google search result. With Firefox 4 it just performs a Google search if you type something which is not recognised as a URL. To get the Firefox 3.6 behaviour on Firefox 4 you need to change a hidden preference. # Type '''about:config''' into the location bar and press enter # Accept the warning message that appears, you will be taken to a list of preferences # Locate the preference '''keyword.URL''', double-click on it and change its value to the link shown below [http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=] If you prefer, you can also do this by installing the Browse by Name extension - https://addons.mozilla.org/firefox/addon/browse-by-name

Question owner

Tried this but it doesn't work. I don't get a google search either when I type anything in the address bar.

Tried this but it doesn't work. I don't get a google search either when I type anything in the address bar.
Klappis 1 solutions 51 answers

It doesn't work with FF 13 anymore, whenever i type something it firefox thinks i typing an adress.

Have you guys removed the search function through adressbar?

It doesn't work with FF 13 anymore, whenever i type something it firefox thinks i typing an adress. Have you guys removed the search function through adressbar?

Modified by Klappis

cor-el
  • Top 10 Contributor
  • Moderator
12497 solutions 115302 answers
What is the current value of the keyword.URL pref? ---- * https://support.mozilla.com/kb/Location+bar+search *https://addons.mozilla.org/firefox/addon/searchreset/
Klappis 1 solutions 51 answers

It's value is "standard"

The keyword.enabled seems to to enabled aswell.

Tried the extension but it didn't work. Whenever i type something in the adress bar (no matter the word) for example Microsoft it ends with http://microsoft/.

Changing the "browser.fixup.alternate.enabled" to false won't work either.

It's value is "standard" The keyword.enabled seems to to enabled aswell. Tried the extension but it didn't work. Whenever i type something in the adress bar (no matter the word) for example Microsoft it ends with http://microsoft/. Changing the "browser.fixup.alternate.enabled" to false won't work either.

Modified by Klappis

cor-el
  • Top 10 Contributor
  • Moderator
12497 solutions 115302 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history.

You can also try to repair the places database with this extension:

You can try to reset Firefox and create a new profile.

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file You can also try to repair the places database with this extension: *https://addons.mozilla.org/firefox/addon/places-maintenance/ You can try to reset Firefox and create a new profile. *https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems
Klappis 1 solutions 51 answers

None of it worked. It stopped working when i upgraded to 13 but im not sure. Is there some zipped version of FF 12 i can check with so i don't spoil my profile?

None of it worked. It stopped working when i upgraded to 13 but im not sure. Is there some zipped version of FF 12 i can check with so i don't spoil my profile?
cor-el
  • Top 10 Contributor
  • Moderator
12497 solutions 115302 answers

If you reset Firefox then a new profile is created and some of your data is automatically imported, but your original profile isn't changed and you can go back to it at any time via the Profile Manager or you can transfer more data to the new profile (be cautious with doing that).

If you reset Firefox then a new profile is created and some of your data is automatically imported, but your original profile isn't changed and you can go back to it at any time via the Profile Manager or you can transfer more data to the new profile (be cautious with doing that). *https://support.mozilla.org/kb/Recovering+important+data+from+an+old+profile
Klappis 1 solutions 51 answers

Aaah yes i knew that but thanks anyway. Tried that method and it wouldn't work either. :(

Aaah yes i knew that but thanks anyway. Tried that method and it wouldn't work either. :(
jscher2000
  • Top 10 Contributor
3386 solutions 30740 answers

Does this only affect one word searches or does it also affect other searches?

For what it's worth, my keyword.URL is a blank string. (Data type is string, value is empty.)

Does this only affect one word searches or does it also affect other searches? For what it's worth, my keyword.URL is a blank string. (Data type is string, value is empty.)
cor-el
  • Top 10 Contributor
  • Moderator
12497 solutions 115302 answers

On which (Windows) platform are you?


Check the connection settings.

If you do not need to use a proxy to connect to internet then select "No Proxy" if the default "Use the system proxy settings" setting doesn't work.

See "Firefox connection settings":

On which (Windows) platform are you? ---- Check the connection settings. *Tools > Options > Advanced : Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then select "No Proxy" if the default "Use the system proxy settings" setting doesn't work. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can
Klappis 1 solutions 51 answers

I've tried everything even made an completely clean install but to no avail. It's not my connection either tried "no proxy" approach but it won't work either.

Doesn't matter if i set the "keyword.enabled" to off or on.

I think the FF devs messed something up. No matter the word it always ends upp with a http:/ before the typed word and if i search for any word containing swedish letter å,ä,ö it's all getting scetchy. I'v added a pic. In the mean time i will revert back to FF 12.

I've tried everything even made an completely clean install but to no avail. It's not my connection either tried "no proxy" approach but it won't work either. Doesn't matter if i set the "keyword.enabled" to off or on. I think the FF devs messed something up. No matter the word it always ends upp with a http:/ before the typed word and if i search for any word containing swedish letter å,ä,ö it's all getting scetchy. I'v added a pic. In the mean time i will revert back to FF 12.

Modified by Klappis

cor-el
  • Top 10 Contributor
  • Moderator
12497 solutions 115302 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

You can try to reset Firefox and create a new profile.

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode You can try to reset Firefox and create a new profile. *https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems
Klappis 1 solutions 51 answers

Thanks! But i've already tried those solutions. I've been running FF since FF 1.5. Shame this problem won't be able to fix. Running older versions with clean installs didn't work either.

Thanks! But i've already tried those solutions. I've been running FF since FF 1.5. Shame this problem won't be able to fix. Running older versions with clean installs didn't work either.
cor-el
  • Top 10 Contributor
  • Moderator
12497 solutions 115302 answers

What is the value of the keyword.URL pref?

You can also try this extension:

What is the value of the keyword.URL pref? *http://kb.mozillazine.org/about:config You can also try this extension: *https://addons.mozilla.org/firefox/addon/searchreset/
Klappis 1 solutions 51 answers

The value is empty aka blank.

The value is empty aka blank.
cor-el
  • Top 10 Contributor
  • Moderator
12497 solutions 115302 answers

You can modify the pref keyword.URL on the about:config page to use Google's "I'm Feeling Lucky" or Google's "Browse By Name".

Google "I'm Feeling Lucky":
Google "Browse by Name":

You can modify the pref <b>keyword.URL</b> on the <b>about:config</b> page to use Google's "I'm Feeling Lucky" or Google's "Browse By Name". Google "I'm Feeling Lucky": * http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q= Google "Browse by Name": * http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q= ---- * http://kb.mozillazine.org/keyword.URL * http://kb.mozillazine.org/Location_Bar_search
jscher2000
  • Top 10 Contributor
3386 solutions 30740 answers

Helpful Reply

What's happening with the non-ASCII characters is that they are being resolved as domains. "Internationalized" domain names (IDNs) containing non-ASCII characters are written in a peculiar set of ASCII characters called "punycode." I know it sounds like I'm making this up, but you can test the theory on this conversion site:

http://mct.verisign-grs.com/

http://en.wikipedia.org/wiki/Punycode

Anyway, I think it indicates that Firefox is trying to resolve the word as a domain (with or without fixup), rather than sending it to search, which is consistent with the behavior of ASCII strings.


Since you're now encountering this issue in all versions of Firefox that you've tested, is it possible that something has changed in DNS resolution on your machine or in your environment? I suppose you could try Google DNS (8.8.8.8, 8.8.4.4) or OpenDNS (208.67.222.222, 208.67.220.220) and see whether that changes anything.

What's happening with the non-ASCII characters is that they are being resolved as domains. "Internationalized" domain names (IDNs) containing non-ASCII characters are written in a peculiar set of ASCII characters called "punycode." I know it sounds like I'm making this up, but you can test the theory on this conversion site: http://mct.verisign-grs.com/ http://en.wikipedia.org/wiki/Punycode Anyway, I think it indicates that Firefox is trying to resolve the word as a domain (with or without fixup), rather than sending it to search, which is consistent with the behavior of ASCII strings. ---- Since you're now encountering this issue in all versions of Firefox that you've tested, is it possible that something has changed in DNS resolution on your machine or in your environment? I suppose you could try Google DNS (8.8.8.8, 8.8.4.4) or OpenDNS (208.67.222.222, 208.67.220.220) and see whether that changes anything.
Klappis 1 solutions 51 answers

Don't know how but i fixed it and not without your help. I changed DNS-servers back and forth and reverted to my providers dns-servers again. Now it works i think, have to test it some more though.

Very thanks again! Appreciated!

Don't know how but i fixed it and not without your help. I changed DNS-servers back and forth and reverted to my providers dns-servers again. Now it works i think, have to test it some more though. Very thanks again! Appreciated!
Klappis 1 solutions 51 answers

Whenever i use my ISP provided DNS-servers it won't work. Whenever i use Googles dns-servers it works again.

How come?

Whenever i use my ISP provided DNS-servers it won't work. Whenever i use Googles dns-servers it works again. How come?