X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I was update my FireFox to 4.0.1,but when i try to intall extension,it report my FireFox is 3.0.8,why?

Posted

I just update my FireFox from 3.5 to 4.0.1,but when i try to intall extensions which need FireFox 4.0.*,it report my FireFox was 3.0.8 and cannot intall.when i choice an extension which suport 3.0.*-4.0.*,it works well.

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • IE Tab Plug-in for Mozilla/Firefox
  • Cssweb HardInfo
  • Cssweb
  • Shockwave Flash 10.1 r53
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729) QQDownload/1.7

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

This is typically caused when an add-on changes the user agent string (identifies the version of Firefox). To rectify this you can reset your user agent string.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click on it and select Reset, this will set the user agent string back to the default in Firefox 4

There are other user agent string settings that may have been modified, but these are no longer used in Firefox 4. You can reset them if you want, for details see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser