X
Tap here to go to the mobile version of the site.

Support Forum

Firefox won't save and quit and the help doesn't tell you what settings to change!

Posted

When I exit Firefox it used to ask me if I wanted to save and quit. Since I upgraded to 4.0, it doesn't do that any more. Now each time I quit and restart, I have to set up my tabs again!

When I exit Firefox it used to ask me if I wanted to save and quit. Since I upgraded to 4.0, it doesn't do that any more. Now each time I quit and restart, I have to set up my tabs again!

Chosen solution

Firefox 4 saves the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.
You can use "Firefox > History > Restore Previous Session" to get the previous session.
There is also a "Restore Previous Session" button on the default about:home Home page.

Another possibility is to use:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Shockwave Flash 10.2 r159
  • 4.0.60310.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

silkphoenix 91 solutions 1257 answers

Please read this thread for further assistance:

https://support.mozilla.com/en-US/questions/815494

Please read this thread for further assistance: https://support.mozilla.com/en-US/questions/815494
Ozamzen 0 solutions 2 answers

Why isn't there an option to save my tabs on exit? Is it really necessary to have to use the "Restore Session" thing to get my tabs back? Why not make it easier and just have the tabs reappear instead of making us go thru the extra step?

Why isn't there an option to save my tabs on exit? Is it really necessary to have to use the "Restore Session" thing to get my tabs back? Why not make it easier and just have the tabs reappear instead of making us go thru the extra step?
cor-el
  • Top 10 Contributor
  • Moderator
17764 solutions 160655 answers

Chosen Solution

Firefox 4 saves the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.
You can use "Firefox > History > Restore Previous Session" to get the previous session.
There is also a "Restore Previous Session" button on the default about:home Home page.

Another possibility is to use:

Firefox 4 saves the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.<br /> You can use "Firefox > History > Restore Previous Session" to get the previous session.<br /> There is also a "Restore Previous Session" button on the default <b>about:home</b> Home page. Another possibility is to use: * [http://kb.mozillazine.org/Menu_differences Firefox (Tools) > Options] > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"
Ozamzen 0 solutions 2 answers

Excellent, thank you.

Excellent, thank you.
mpz 0 solutions 11 answers

None of this helps. The "restore session" option is not highlighted and not useable. Is it no longer possible to restore tabs and windows?

None of this helps. The "restore session" option is not highlighted and not useable. Is it no longer possible to restore tabs and windows?
cor-el
  • Top 10 Contributor
  • Moderator
17764 solutions 160655 answers

Make sure that you not run Firefox in (permanent) Private Browsing - Use Firefox without saving history mode.

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Permanent Private Browsing mode"
Make sure that you not run Firefox in (permanent) [[Private Browsing]] mode. * You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" * To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Uncheck: [ ] "Permanent Private Browsing mode"