X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I cannot open SHORTCUTS in the FIREFOX browser. The bookmark opens in another browser.

Posted

I cannot open desktop SHORTCUTS in the FIREFOX browser. The bookmark opens in another browser.

Modified by whoo

Chosen solution

Click the orange Firefox button, go to Options | Options | Advanced and make sure Always check to see if Firefox is the default browser on startup is checkmarked.

You might want to check the other browser to make sure something similiar isn't checkmarked there as well.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 10.2 r152
  • iTunes Detector Plug-in
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

nothing else

Xircal 334 solutions 3835 answers

Chosen Solution

Click the orange Firefox button, go to Options | Options | Advanced and make sure Always check to see if Firefox is the default browser on startup is checkmarked.

You might want to check the other browser to make sure something similiar isn't checkmarked there as well.

Question owner

Actually, the problem somehow solved it self somehow. All my desktop shortcuts now open in FireFox. However, I did go ahead and check the 'always check...' box. Bill

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Shortcuts that you create by dragging the icon on the location bar to the desktop will always open in the default browser.

Control Panel > Add/Remove Programs > "Set Program Access And Defaults" (on the left)
Open: Custom (click arrow on the right)

Question owner

Which control panel? Where is it ? How do I get to it ?

Question owner

- The problem is back. It was fixed for a while but now is back.

While using Firefox and having it set as the default browser, I create a desktop shortcut by dragging a site's icon from the navigation bar (thank you Firefox for renaming the 'address' bar the 'navigation bar) to the desktop. However, the icon that appears is that of Avant browser (another browser I use). When I click on it the thing opens in Avant browser not Firefox.

What gives ??? -

Question owner

- I am using Win 7 and don't have the links suggested by Cor-el. -

Modified by whoo