Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

browser.startup.homepage_override_urlhttp://search.speedbit.com how do i change this it keeps making my home page search speed bit and it sucks i have this problem on ff4

  • 1 reply
  • 26 have this problem
  • 4 views
  • Last reply by paulff

more options

i have this on ff4 and cant get rid of it i have gotten rid of everything on my comp that deals with this

All Replies (1)

more options

everyone should try this copy and paste link into address bar

http://www.speedbit.com/faq/#faq32

then look down the list for

How can I remove SpeedBit Search from my computer?

then go to; Restore Browser Defaults Utility. this is high lighted in blue. then save and open. it worked for me good luck