Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I use firefox 4, but i can't install addons compatible with firefox 4..

  • 2 replies
  • 4 have this problem
  • 4 views
  • Last reply by neranga

more options

I am using Firefox version 4. but i can't install add-ons which are compatible with firefox 4.

Those add-ons show my Firefox version as 3.0

Please help. Thanks in advance

I am using Firefox version 4. but i can't install add-ons which are compatible with firefox 4. Those add-ons show my Firefox version as 3.0 Please help. Thanks in advance

All Replies (2)

more options
more options

Thank you very much for the reply. Actually the above page was not helpful to me, but when i got there i saw in general.useragent.override

general.useragent.override;Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0 MEGAUPLOAD 1.0

This is because of I have installed megaKermit script. So I changed the 3.0 to 4.0. It solved the problem..

I hope this will help for others who have installed the megaKermit script.

Thanks a million for your kind reply.

Modified by neranga