Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Robo form not running on FF ver 4

  • 20 replies
  • 80 have this problem
  • 50 views
  • Last reply by mr.msb

more options

Hi I am using a Dell laptop running win7 my FF 3.6.16 runs roboform ver 6 no problems. I have also been running FF ver 4 which has also worked OK until a few days ago when it did an update. Now the Roboform tool bar is empty except for the Roboform Icon which if you run the pointer over it says "show or hide tool bar" but if you click on the Icon it Just loads the roboform download page. I cannot move over to using ff ver 4 until roboform works

All Replies (20)

more options

Firefox 4 requires an update to Roboform 7 and that version needs to be purchased and is no longer free.

You can look at this extension as a possible replacement for Roboform:

more options

I am running Roboform ver 6 which I purchased and has about 76 passwords in its data base and it has been working with FF 4 until a recent update

more options

Firefox 4.0 hasn't been updated since it was released like 3 1/2 weeks ago.

You posted here with Firefox 3.6.16, is that on a different PC? Or are you using both Firefox 4.0 and 3.6.16 on the same PC? If so, did you create a new Profile for 4.0? Using the same Profile for both versions can lead to a myriad of problems.

more options

Hi I responded to a communication from Firefox which said why no try FF 4.0 which I did and it downloaded ver 4.o so I am running both versions on the one laptop without a new profile, the only problems I have had before roboform is that there is an interaction between both versions and this slows down the booting up sequence. would you recommend deleting the version 4.00 and then updating 3.16 to 4.00 so that there is only one version running

more options

Switch to LastPass.

I was torturing myself for weeks comparing features, etc. Then I read, and confirmed myself, that Roboform has removed it's export features in the most recent version.

Obviously, this was intended to keep people from leaving Roboform.

Well, that was all I needed to convince me to move. When a company is so insecure about it's product as to remove features making it easy to leave, that should be a HUGE warning sign about the integrity of the company and product.

more options

I've downloaded Roboform lite which is free. A new icon appears on Firefox then clic on it and choose the third solution "only store data on my computer", or something like that and now it works correctly (sorry for mistakes but I'm french). Hope it could help you.

more options

Please fix this problem i use Firefox heavily, and i require Roboform.

more options

@astok - This is not a problem that Mozilla needs to fix, you need to update Roboform so it is compatible with Firefox 4.

more options

I've just rewound the spool to run Firefox Version 3 after updating to 4. I tried ver 4 a while ago, but I couldn't use Roborm with it then. I purchased Roborm 6 and I don't intend to buy the new verison just so that I can use Firefox 4. Thanks anyway.

more options

Roboform 6.x was only free for 10 or less passwords, and was a "one-time" purchase. When ver 7.0 came out and they want to charge an Annual "subscription" fee for what they offered at no charge in 3.x (online sync and backup of your data). Now they wast to charge $20 a year for an "Everywhere online account". All my data combined was only 1.4Mb.

There was no problem in FF 3.X but in FF 4.X RF 6.X quit working.

A typical "BAIT AND SWITCH" tactic. DO NOT USE ROBOFORM unless you want to pay and pay and pay...

Looking at alternative programs now...

more options

Thank you all for your help, I have now updated FF to version 4 and I have also updated my Roboform to version 7 All now seems to be working Ok

more options

I run RoboForm v7.2.0 and also RoboForm Everywhere - I 'm fully paid up with RoboForm. I use Firefox to access the sites I need to log into using RoboForm - hey, am I alone in thinking a browser is a tool, not an end in itself??!! Firefox V4 BARP - RoboForm doesn't work with it, this was 'crisis-time' yesterday after "upgrading" to v4 until I realised it's not user-deficiency on my part, it's a problem in Firefox, so I reverted to FFv.3.17 AND had to re-install and reactivate RoboForm. Now it's all sweet. Let me know when FF v4 works with Roboform, please!

Modified by ebrown

more options

I was fine with version 6 until Firefox updated to 4.0.1. Roboform did not work after that (toolbar diplayed, but couldn't use). This workaround allowed me to use version 6 with Firefox 4.0.1.:

  1. Install Roboform version 7
  2. Copy folder "c:\Program Files\Siber Systems\AI RoboForm\Firefox\"
  3. Uninstall version 7
  4. Install Roboform version 6 -dont untick option to install adapter for firefox
  5. Replace "c:\Program Files\Siber Systems\AI RoboForm\Firefox\" with your copy from version 7

Modified by fdog

more options

Oh, YES, it is. Roboform did not change, FireFox however, DID. You guys have still not answered the question, that is, "What code did you change in FF4 to make it not work with RF6.10.2?" Tell me where the code is so I can yank it out of my version of FF4. Or is it a matter of Roboform donating money to Mozilla so that the next iteration of FF will require a new purchase of RF?

BTW, FF4 is neither faster nor easier to use . If you are going to change FF, why not make all of the changes security related, and then offer the fluff as extensions or addons? Volkswagon's Beetle made good use of mechanically refining the vehicle, instead of adding nonsense fashion changes every year. It made sense.

As a matter of fact, the best version of Firefox in look and feel and speed was Firebird. A slim, minimalist tool. It's a shame you guys quit on that one.

more options

The main "code" that was changed which seems to be affecting Roboform was the Firefox version number, Roboform version 6 was compatible with most of the 4.0betas with the installation of the "4.0 beta extension" from Roboform. Sometime around 4.0b12 and the release of 4.0 it seems that Roboform decided that a money making opportunity was at hand, and compatibility was gone for version 6.

Bascially, when an extension is developed for Firefox, the developer sets the maxVersion number for the current version of Firefox. When the maxVersion is lower than the version of Firefox that is installed, the extension is disabled. It is up to the developer of each extension to keep it up to date as new Firefox versions are released. Easy to do with extensions hosted at the AMO website, a simple "bump" in the Developers Console and every installed extension in the world becomes updated automatically as the new version of Firefox is installed. For extensions not hosted at AMO, the developer can specify their own secure updates.xml page where Firefox can look for updates every time Firefox is launched.

Regardless of what a user may think, Firefox is the primary application when it comes to extensions installed into Firefox. Extension developers have to "cater to Firefox" as far as following the rules that are set down by Mozilla; "money" doesn't enter the equation as far as Mozilla is concerned. When Firefox is changed, extension developers need to change their extensions to keep pace.

more options

Spreading the word. The fix fdog listed above even works for the latest Firefox (V5).

Modified by billybob62

more options

Need some help urgently....

I have followed the steps outlined above but can't get it to work....

Might be a dumb question - but how do you copy the folder file? "c:\Program Files\Siber Systems\AI RoboForm\Firefox\"

Where do you save the file to? Do you save it in c:\Program Files????

Appreciate your assistance... Regards

more options

Thank you for the detailed explanation. Sorry for the tone of my last post. Just frustrated about the RF $ grubbing.

more options

Thank you very much.

more options

Oh I forgot, where is this AMO website? I never heard of it.