X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Binding "close" to a mouse button closes Firefox 4 instead of the active tab as in previous versions.

Posted

I have a 5 button Microsoft mouse. In the mouse properties, I have "Close" bound to one of the buttons. In previous versions of Firefox, that would close the active tab. With Firefox 4, it closes the browser. Is there a way to get this functionality back?

Chosen solution

This response seems to have solved the issue for others:

"I have a similar issue in that I programmed my MS Mouse Intellipoint to "Close" so I could close a tab with a click but now it closes the application. I got around it by changing my Intellipoint settings / Program Specific Settings / Firefox / Keystroke (Ctrl + W) Hope this helps"

Quoted from https://support.mozilla.com/questions/820420

Read this answer in context 15

Additional System Details

This happened

Every time Firefox opened

This started when...

Upgrading to Firefox 4

Installed Plug-ins

  • Logitech Device Detection
  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r153
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • DLM Netscape Plugin (2.3.10.115)
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

onetime 0 solutions 5 answers

I am using Firefox 6 and the problem are still there. I have this problem happening with my notebook, the desktop in my work and my home desktop. All using Windows 7 64bits and using Microsoft Intellipoint (latest version) to assign the "close" command to the button.

I have in one computer an Microsoft Wireless Mouse 6000 and in the two others a Microsoft Comfort Mouse 3000. It appears that the mouse model don´t matter.

I don´t have this problem with Firefox until versions 4, 5 and 6.

IE, all versions, including 9 and with Chrome also all versions, including 13.0.782.215 don´t have the problem. Opera 11.50 also works correctly. Other types of programs that open tabs, like notepad++ also works correctly. Vmware that also have tabs, works correctly too.

In Firefox 6 the close button close all tabs instead of only the active one.

This bug is know for months and it appears that no one at Firefox is working on this. And as this behavior is good in all other programs that I found using tabs, it looks like Firefox is doing something wrong.

It is very nice to bind a button to close a tab, it save some time.

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

Which code is that keyboard sending to Firefox if you use that button?

To close the active tab you need Ctrl+W or Ctrl+F4
Make sure that the Shift key isn't pressed because Shift+Ctrl+W will close the window.

onetime 0 solutions 5 answers

Cor-el, I just choose "close" in a drop down list in the Intellipoint program.

Maybe Firefox from 4 to forward is treating the "close" command as "exit" command. (just a guess)

I am not using the shift key together with the mouse button mapped to the "close" command. The interesting thing is that this same "close" button work closing only the active tab in firefox 3.6 and lower and today versions of Chrome, IE, Opera, Notepad++, Vmware and probably other programs that use tabs.

There is a way that I can find what "exactly" is my mouse sending to the Firefox application?

onetime 0 solutions 5 answers

I am using Firefox 6.0.1 now and the problem is not solved.

David Tenser
  • Administrator
  • Moderator
32 solutions 294 answers

Chosen Solution

This response seems to have solved the issue for others:

"I have a similar issue in that I programmed my MS Mouse Intellipoint to "Close" so I could close a tab with a click but now it closes the application. I got around it by changing my Intellipoint settings / Program Specific Settings / Firefox / Keystroke (Ctrl + W) Hope this helps"

Quoted from https://support.mozilla.com/questions/820420

isaacchanks 0 solutions 1 answers

Thanks buddy. You are the man !!

onetime 0 solutions 5 answers

Helpful Reply

The suggestion from djst really works, many thanks. But it is sad that in version 7.0.1 Firefox still behave different (regarding close tabs) than Opera, Chrome and IE. And it needs an special configuration for this function.

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

Set the pref browser.tabs.closeWindowWithLastTab to false on the about:config page to prevent closing the last tab from closing the browser and make a close button appear if only one tab is open.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold (user set).
  • Preferences can be reset to the default via the right-click context menu if they are user set
  • Preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean)