X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how to remove avg secure search

Posted

I can't get rid off AVG secure search, I uninstalled avg and it still shows up when I search from the navigation toolbar.

Chosen solution

Hi, I was able to remove it but simply removing Search AVG from the "pre-selected" search engine. You can do this from the search box on the top RHS (see print screen). Click on the logo of your default search engine and you will see the list of all the search engines available. Simply remove AVG and you are done. Hope it will help

Read this answer in context 113

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • Version 1.9.2.0
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Google Update
  • Shockwave Flash 10.2 r153
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

goosnguns 0 solutions 1 answers

This AVG secure Search is driving me CRAZY!!!!! I uninstalled AVG weeks ago, there's no AVG files on my add/remove page. I made Google my search engine...twice and it's still there!! Every answer I've found says to uninstall AVG! That obviously does NOTHING. PLEASE help me get rid of this thing. I'm so tired of having to type in Google.com every time I want to search for something.

gmayock 0 solutions 1 answers

I am suffering from the same thing! It just happened a few days ago. I checked all settings, removed AVG ... nothing.

Please FFS help me find a solution for this. I'm gonna poop brix if I can't get rid of this.

Nijshu 0 solutions 1 answers

I had this frustrating problem too, so I went to about:config and set the "keyword.URL" value to http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=. This helped change the main nav bar search to Google, but I still couldn't change the homepage search.

Eventually, I switched my homepage to http://www.google.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official; this is the old Firefox homepage, but at least AVG search isn't used on this page.

However, I'm still looking to be able to use the new, cleaner looking about:home page and use it with Google search. Any help would be appreciated.

ralphbusdriver 0 solutions 19 answers

Helpful Reply

The above did not work for me - it merely reverted back.

I previously disabled all AVG extensions and removed the AVG software (replaced with MSE) - still stuck with the AVG secure search. Here was my fix:

I went into Firefox with the about:config in the address bar used the filter to find all "browser.search" items. About 3 or 4 of the found items had AVG in them and I selected "reset" for each of them. My FF browser still had the AVG secure search in the search box, but it then also had the drop down menu in the search box back. Inside that drop down menu that was previously missing, I used the manage search engines option and deleted the AVG secure search option and all works well again.

While I was in the browser setting area I changed the Google search site value http://www.google.com/search?ie=UTF-8&oe=UTF-8&q= by adding an "s" after "http" to make it more secure.

Hope this fix works for others. I'm done with the invasive AVG forever, or at least until MSE starts to do similar things.

Modified by ralphbusdriver

cgresse 1 solutions 1 answers

Chosen Solution

Hi, I was able to remove it but simply removing Search AVG from the "pre-selected" search engine. You can do this from the search box on the top RHS (see print screen). Click on the logo of your default search engine and you will see the list of all the search engines available. Simply remove AVG and you are done. Hope it will help

JimPazzoom 0 solutions 1 answers

None of the above fixes worked for me. But I got rid of the AVG redirected search by removing a remaining AVG folder from the ProgramData directory on the main drive (C:) of my computer. Then I rebooted Windows. I'm using Windows 7, so this may or may not help with other users. ProgramData is by default a hidden directory. So I had to temporarily change the view setting in my folder options.

eljefe6767 0 solutions 1 answers

I'm stuck w/ this problem too. Although I'm not a computer wizard, I get the distinct feeling this is a battle of wills/attrition and AVG/Mozilla is trying to wear me down and finally relent to being compelled to use this less satisfactory search method. I am already on hour 2 of trying to undo what was done. Who has this kind of time to waste? This is exactly the type of thing I was trying to avoid when I switched from Internet Explorer to Firefox. That they would let this crap go on is a big strike against Mozilla.

jipejena 0 solutions 3 answers

I don't understand where to go for this. Please treat me as a total idiot and explain step by step (without shorthand abbreviations) what to do. Thanks.

jipejena 0 solutions 3 answers

Thanks for the info. I wasn't quite sure if i was doing things right, but when I rebooted my computer....VOILA! That pesky AVG search bar is gone and now I have the Google search bar in the upper right hand corner just like someone else said I should have.

jipejena 0 solutions 3 answers

Until I did the solution by ralphbusdriver, I did NOT have Google search bar on the right hand side of my screen so the suggestion by smilingbranch did not work.

frenchbruce 0 solutions 10 answers

Am I just one of the many Firefox users who have been caught by the Automatic Firefox update and now find that on the left hand side of the screen you have the "Sites Checked by AVG nonsense... I don't want this rubbish on my Firefox opening page...how can I get rid of it? I've uninstalled the AVG software...restarted..and the same Sites Checked rubbish comes up?...Has Firefox allowed AVG to plant this rubbish into their update? Rumour has it that AVG get paid each time it pops up on the opening search page. Is this true....? have Mozilla lost the plot!

johnnyhamish 0 solutions 1 answers

Helpful Reply

I had the same problem, and I tried a couple of these but it just returned. Finally found this : http://forums.avg.com/ww-en/avg-free-forum?sec=thread&act=show&id=157513 , 1) Type in address-bar about:config and press Enter 2) Confirm warning dialog 3) Find keyword.URL (you can use Filter) 4) Change value of keyword.URL to http://www.google.com/search?ie=UTF-8&oe=utf-8&q= I didn't change value to this, just reset it. Maybe it only disables it, but I haven't found it anywhere since.

FeatherDragon 0 solutions 1 answers

None of this works for me.

I have discovered that creating a new Firefox profile does solve this problem.

However, I would like to know how I can fix my current profile. I have many tabs open and regularly saved on it that would be a real pain to transfer over to the new profile.

So, bearing in mind that there's something unique to my current profile that causes the AVG search page to be shown every time I enter a search query and hit enter, what can I do to fix this? I'm assuming it must be something in the about:config page that has been missed.

Scruffyo_0 0 solutions 2 answers

1) Type in address-bar about:config and press Enter 2) Confirm warning dialog 3) Find keyword.URL (you can use Filter) 4) Change value of keyword.URL to

http://www.google.com/search?ie=UTF-8&oe=utf-8&q=

Scruffyo_0 0 solutions 2 answers

Although... the above wasn't entirely successful - delve a little deeper into about:config, filter agv and hack the agv stuff out...

MarleneW 0 solutions 2 answers

This is how you do it, from the horse's mouth (AVG, whom I emailed with my problem).

proceed as follows to resolve this issue:

1. Click on the AVG logo drop down on the toolbar and then click on Options 2. Once the Options Dialog has opened, click the "Advanced Options" Tab 3. Untick all of the options appearing in this screen, and click OK

Note: To access the Toolbar Options, be sure that the AVG Toolbar is visible in your browser. Click on View -> Toolbars and make sure AVG Security Toolbar is checked.

probSolver 0 solutions 2 answers

I'm currently running FF 5.0 on WinXP/Win 7 x64 Pro and this is the solution that I developed to solve this problem. In order to implement it, you will first need to install the uc extension (if not already installed), which will allow you to run your own custom JavaScript in FF. Once installed, you can create a file called fixSrch.uc.js, add it to the %appdata%\Mozilla\Firefox\Profiles\xxxxxxxx.default\chrome directory, and add the following code to it to reset the search engine back to the desired one (Google in my case):

// ==UserScript==
// @name            fixSrch
// @desc            fixes the search engine on the about:home page.
// @version         1.0
// @author          probSolver, (c) 14-Aug-11 19:48
// @include         main
// ==/UserScript== 

Components.utils.import("resource://gre/modules/Services.jsm");
Components.utils.import("resource://gre/modules/FileUtils.jsm");

function fixSrchEngine()
{
   // get the URI handle of the about:home page.
   let aboutURI = Services.io.newURI("moz-safe-about:home", null, null);
   
   // temporarily grant the forthcoming JavaScript extended privileges 
   // on the about:home page by getting its codebase principal -- i.e., 
   // accepting its authorization based on origin instead of digital 
   // signature).
   let principal = 
      Components.classes["@mozilla.org/scriptsecuritymanager;1"].
      getService(Components.interfaces.nsIScriptSecurityManager).
      getCodebasePrincipal(aboutURI);
   
   // open an instance of the DOM's Storage Manager.
   let dsm = Components.classes["@mozilla.org/dom/storagemanager;1"].
             getService(Components.interfaces.nsIDOMStorageManager);

   // access the localStorage of URI's (about:home) codebase principal.
   let ls = dsm.getLocalStorageForPrincipal(principal, "");
   
   // prepare the desired search engine's values -- i.e., name and URL 
   // -- and store them in an object-like structure.
   var engineName = "Google";
   var engineUrl = "http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a";  
					
   let engine = { name: engineName, searchUrl: engineUrl }
   
   // set the localStorage's 'search-engine' key to the search engine's 
   // values in string-only format as required by HTML5's 
   // localStorage().
   ls.setItem("search-engine", JSON.stringify(engine));
   alert('The search engine has been reset to ' + engineName + '!');
}
fixSrchEngine();

As is, this script will invoke the search engine-fixing function each time FF is launched, which is probably not what you want. A better approach might be to tie the function to the oncommand attribute of one of FF's menuitems via an overlay (.xul file); that way, you can quickly reset the search engine if it is modified by updates or the like in the future. That is actually how I did it; I added a customized menuitem (see the snippet below) to a custom overlay.

<menuitem id="srcheng" label="Fix Search Engine" oncommand="fixSrchEngine();" />

In short, I truly hope that this helps others who are experiencing this frustrating problem.

david5h 0 solutions 1 answers

This frustrated the hell out of me. I was typing http://www.dailygrooming.co.uk directly into my search bar and it was redirecting me to the avg search results! The fix by johnnyhamish worked for me:

1) about:config into browser url bar 2) agree to the warning 3) type avg into the search, on mine I got 2 results 4) right click the results and reset

Job done!

Bandito77 0 solutions 1 answers

DO EXACTLY WHAT Nijshu SAID:

"I had this frustrating problem too, so I went to about:config and set the "keyword.URL" value to http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=. This helped change the main nav bar search to Google, but I still couldn't change the homepage search.

Eventually, I switched my homepage to http://www.google.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official; this is the old Firefox homepage, but at least AVG search isn't used on this page.

However, I'm still looking to be able to use the new, cleaner looking about:home page and use it with Google search. Any help would be appreciated."

THIS WILL SOLVE THE PROBLEM...on a side note...FUCK YOU AVG!!!!!!!!!!!

jhqpinto 0 solutions 1 answers

The solution by cgresse does the trick, but only superficially.

If you decide to type the search words on the address bar, AVG will be used as the search engine. The solution given by cgresse is not complete.

To remove AVG Secure Search:

In the address bar, type this --> about:config

Press Enter

Confirm the dialog and warning

In the FILTER box, type this --> keyword.URL

Right click on keyword.URL and change it to http://www.google.com/search?ie=UTF-8&oe=utf-8&q=

I tried to reset it, but it reverted to AVG

This solution is available at http://forums.avg.com/ww-en/avg-forums?sec=thread&act=show&id=157513

It was previously given here by johnnyhamish (see further up).

Modified by jhqpinto