X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

keep getting popup coupons - says that it can be deleted by clicking coupon button on menu bar but I don't see one

Posted

Recently started getting a lot of popup coupons - on the coupon it says that you can stop this by clicking on coupon button on menu bar but I do not see a coupon button on any of the menu bars. How do I delete this problem? Thanks

Chosen solution

That's good news. Are you still using Windows XP?

Read this answer in context 0

Additional System Details

This happened

A few times a week

Installed Plug-ins

  • np-mswmp
  • npunagi2
  • ZoneAlarm Spy Blocker Plugin Stub for 32-bit Windows
  • Google Gadget Plugin 5.7.712.19360
  • Pando Toolbar Plugin Stub for 32-bit Windows
  • npdnu
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 10.2 r153
  • npFFApi
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.60129.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Photodex Presenter Plugin 4,50,0,2949
  • Yahoo! activeX Plug-in Bridge
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

sctl 36 solutions 219 answers

Your Firefox and plug-ins are outdated and introducing security risks to you which can be a reason for unwanted popups. Outdated software can allow malicious people on the internet to take control of your machine without you knowing. Download a new version of Firefox. Uninstall the old version, then install the new version.

After updating Firefox, to update your plug-ins, go to:

   https://www.mozilla.org/en-US/plugincheck/

and find the ones to be updated, then update them.

Safe browsing requires vigilance, and this includes making sure you have programs installed on your computer to protect you online, and that they are regularly updated.

Steps to take:

  • Updating everything can be time-consuming, and if you're not sure what to do, use a program like Secunia's Personal Software Inspector (PSI) to help automate the process of updating all software on your computer.
  • Make sure Windows Update is turned on and set to automatic.
  • Always run antivirus software -- there are many free programs from vendors like Avast, AVG, TrendMicro, etc.
  • Make sure your Windows firewall is on (if you are not using a replacement firewall, if so, keep that one up to date).
  • Make sure your browsers are the latest versions.

Once you get everything up-to-date, then install a couple of helpful add-ons to your new Firefox installation:

  • NoScript will only turn on scripting (automated web-page actions) for websites that you trust.

After you've updated everything and have your new add-ons installed, you'll be safer on the web and should not be bombarded by adverts.

pbarnak 0 solutions 2 answers

I have finally figured out where these popups are coming from. They are connected to toolbars. I run IE9 and with the yahoo toolbar I had the coupons button active. It is from Viscom. All I had to do is go to the toolbar settings and uncheck the coupon button. I still kept the yahoo toolbar. Totally stopped these half coupons that would show up on Best Buy, CompUSA, Staples, etc. I have also read that they have been found on the Xfinty toolbar. Hope this works for everyone.

Question owner

I am using Firefox as a browser and do not have any add on toolbars. Firefox is up to date with all the recommended add ons and the pop up coupons seem to have stopped at last.

sctl 36 solutions 219 answers

Chosen Solution

That's good news. Are you still using Windows XP?

Question owner

nope - have been on Windows 7 for about 8 months now - very happy with it

sctl 36 solutions 219 answers

Well glad to hear it, and that your pop-up problems are solved.

Did you install the Secunia PSI tool I mentioned above? That will help keep most of your programs up-to-date.

gggcc 2 solutions 11 answers

You have to kill it in two places. FF must be generating revenue from this.

Goto Add-ons

1) Click on the Plug Ins tab.

   Disable both "Coupon Inc" addons.  For some reason I had two.

2) Click on the Extensions tab

   Disable the "Start Now toolbar"

What a pain.