X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Will there be an update for DigitalPersona Extension 5.0.0.3790 to provide compatibility for FF4?

Posted

When downloading Firefox 4.0, DigitalPersona Personal 4.11.3805 with DigitalPersona Extension 5.0.0.3790 (from Mozilla Firefox Add-Ons) is incompatible. Fingerprint swipes only open the DPP application's Home Page. I had to uninstall FF 4 and re-install FF 3.6.16 in order to utilize fingerprint logon recognition.

DigitalPersona will no longer support DigitalPersona Personal as is evidenced by the following email I received from PersonalSupport@digitalpersona.com:

"Thank you for contacting DigitalPersona. We are extremely sorry to inform you there will be no update releases for DigitalPersona Personal in the future. We are also sorry to inform you there will be no updates for Firefox 4 nor Internet Explorer 9. You certainly can try to use either one, if they work for you great!. If they do not work, you will have to decide to either keep DPPersonal and forgo Firefox 4 or IE 9, or vice versa. DigitalPersona, regretfully, is leaving the consumer market and is focusing on numerous business and legal applications. In fact, again sorry to inform you, DigitalPersona Personal will not be supported after Mid-April of this year."

Hardware/Software:

Computer: HP DigitalPersonal Personal: 4.11.3805 OS: Windows 7 64bit Browser: Firefox 4 Fingerprint Reader Sensor: Validity Driver: 2.0.0.1

Will there be an update to this extension, or are there other software options to make the Validity Sensors, Inc. fingerprint reader compatible with FF4?

Modified by b.rose.taos

Additional System Details

Installed Plug-ins

  • npmnqmp 989898989877
  • np-mswmp
  • My Web Search Plugin Stub for 32-bit Windows
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Winamp Application Detector
  • Default Plug-in
  • Shockwave Flash 10.2 r153
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Windows Activation Technologies Plugin for Mozilla
  • 4.0.60129.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 GTB7.1 (.NET CLR 3.5.30729)

More Information

as above and HP community forum provides no solutions

TonyE
  • Moderator
1041 solutions 8840 answers

As Digital Persona have abandoned it, there will be no update to their extension. It may work with the Fingerfox (SE) extension - https://addons.mozilla.org/firefox/addon/fingerfox-se

Jape80 0 solutions 1 answers

Helpful Reply

I've asked HP about the problem and they washed their hands from it. The answer came from Finlands hp support so I translate the main points here.

-Because Firefox 4 doesn't come with the computer the compatibility problem doesn't belong to our support, please contact Firefox support for solving the problem.

So you could say that when you buy something and change or update the system it won't be supported anymore because it's not the same when you bought it...

my3sonskdj 0 solutions 2 answers

download and save Firefox 3.6 to your desktop for future installation. http://www.mozilla.com/firefox/all-older

Close Firefox 4, and uninstall it. Do not remove your personal data and settings, just the program.

Then finally you can reinstall Firefox 3.6.

mikoscience 0 solutions 2 answers

Helpful Reply

IE8, IE9 and IE10 beta supports DigitalPersona off the box. I wonder why cant Firefox do the same?

CanteburyGhost 0 solutions 6 answers

You don't need this Extension. But it is hell (for a normal person) trying to remove it. (Because you probably still want to keep the rest of the program to be able to login.) You have to rename/delete some files and edit the registry to be sure it's not there.

[Assuming Vista, Firefox 7.0.1]

1) Rename the directory:

   C:/Program Files/DigitalPersona/Bin/FirefoxExt  

2) Carefully remove all the Registry entries related to that plugin, by running "regedit". Check for entries of the digital persona plugins. DO NOT REMOVE anything else related to DigitalPersona or you may not be able to login using your fingerprint!

a) Find the registry entry:

   HKEY_CURRENT_USER\Software\Mozilla\Firefox\Extensions\
   Remove the "otis@digitalpersona.com" REG_SZ item.

b) Find:

   HKEY_CURRENT_USER\Software\DigitalPersona\Applications\OTAppSettings
   
   Edit the REG_DWORD of "IntegrateWithFirefox" from "1" to "0".

c) Check and remove related DP registry entries here.

   HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Firefox\Extensions\
   HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\

Good Luck!

Modified by CanteburyGhost

metaC0R3tex 0 solutions 1 answers

Under 'C:/Program Files/DigitalPersona/Bin/FirefoxExt ' (for 32-bit) or 'C:/Program Files (x86)/DigitalPersona/Bin/FirefoxExt ' (for 64-bit);

In file install.rdf , modify value 3.* to 8.* in string em:maxVersion

Enjoy.

Modified by metaC0R3tex

moose34 0 solutions 1 answers

when i try this...

In file install.rdf , modify value 3.* to 8.* in string em:maxVersion

it doesnt work when i swipe my finger in firefox (7.0.1)

please help

Modified by moose34

jbatl 0 solutions 2 answers

This sucks. Why are PC manufacturers continuing to sell units with fingerprint readers if Firefox, Google and Microsoft won't provide updates to support them? I love using my reader. I forgot most of my passwords because of it and now I have to reset them all so I can move from FF 3.6. As Digital Persona provided something that I paid extra for but now is obsolete! What a load of crap!