Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Downloaded new verson and now it says I can't use the app. with my version of mac OSX 10.4.11

  • 5 replies
  • 69 have this problem
  • 9 views
  • Last reply by James

more options

I have a Mac with 10.4.11 and have used Firefox for a long time. Today I got a prompt to upgrade Firefox and when I did, the prompt comes up saying I can't use the application Firefox with my version of Mac OS X. I have had to go back to an older version of Firefox and have lost my bookmarks and don't have a tab bar, etc. What do I do now. I am not very computer savvy, but I have tried to search on how to fix it, but to no avail.

I have a Mac with 10.4.11 and have used Firefox for a long time. Today I got a prompt to upgrade Firefox and when I did, the prompt comes up saying I can't use the application Firefox with my version of Mac OS X. I have had to go back to an older version of Firefox and have lost my bookmarks and don't have a tab bar, etc. What do I do now. I am not very computer savvy, but I have tried to search on how to fix it, but to no avail.

All Replies (5)

more options

Unfortunately, Firefox 4 supports only Mac OS X 10.5 and above on Intel hardware. The system that you are currently using is no longer supported by Firefox (details can be found here). The prompt that you got to upgrade was an error on part of Mozilla and they are trying to fix it so it does not happen again.

You should revert back to previous version (3.6.16) of Firefox by following these steps:

  1. Open the Applications folder.
  2. Drag the Firefox application to the Trash.
  3. Download and install Firefox 3.6 from here.
more options

Thank you, but I can't open the download and install where you said to click "here". Where do I go to get this version 3.6.16?

more options

You will get Firefox 3.6.16 at this location: http://www.mozilla.com/en-US/firefox/all-older.html. You need to download the Mac version of your preferred langauge.

After downloading, install by following the steps given in this article: How to download and install Firefox on Mac.

Let us know if you face any problems.

more options

You CANNOT get version 3.6.16 from that link. I need 3.6.18 or earlier. Where can I find it? Or HOW do I revert from the non-working 3.6.19 on my computer back to 3.6.18 that was working yesterday?

more options

Well because the 3.6.16 was the current version then.

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.6.18/mac/

And then pick your language and download the Firefox 3.6.18.dmg