X
Tap here to go to the mobile version of the site.

Support Forum

Can't remove Skype from Toolbar

Posted

Version 4:

I can't remove the Skype button on the Toolbar. I attempted to Customize the Toolbar and drag it from the Toolbar.

The other items that I did this with worked just fine but have had no luck with the Skype button.

I just looked at my Extensions and for some reason, Skype is enabled in my Extensions.

Not sure how or why but even so how would that effect my Toolbar?

Version 4: I can't remove the Skype button on the Toolbar. I attempted to Customize the Toolbar and drag it from the Toolbar. The other items that I did this with worked just fine but have had no luck with the Skype button. I just looked at my Extensions and for some reason, Skype is enabled in my Extensions. Not sure how or why but even so how would that effect my Toolbar?

Chosen solution

You need to disable the Skype extension. Click the Disable button if you can't uninstall (Remove) it.

See:

Read this answer in context 6

Additional System Details

This happened

Every time Firefox opened

This started when...

From the beginning on my installation of Version 4

Installed Plug-ins

  • IE Tab Plug-in for Mozilla/Firefox
  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • Version 1.9.2.0
  • 1.9.0042.0
  • 2.0.0048.0
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • CouponNetwork Coupon Activator
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.2 r152
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Live Update v1.5
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
13042 solutions 119425 answers

Chosen Solution

You need to disable the Skype extension. Click the Disable button if you can't uninstall (Remove) it.

See:

You need to disable the Skype extension. Click the Disable button if you can't uninstall (Remove) it. See: * [[Troubleshooting extensions and themes]]

Question owner

That did it.

Thanks for the prompt response.

That did it. Thanks for the prompt response.
the-edmeister
  • Top 10 Contributor
  • Moderator
4134 solutions 31174 answers

When you are logged in, please click the Helpful button next to the answer that solved your Firefox support issue, so this thread gets marked as Solved.

When you are logged in, please click the '''Helpful''' button next to the answer that solved your Firefox support issue, so this thread gets marked as '''Solved'''.
freebirdwil 0 solutions 7 answers

Need to uninstall not just disable. It's not in the extensions folder of profile either?

Need to uninstall not just disable. It's not in the extensions folder of profile either?
freebirdwil 0 solutions 7 answers

Solution courtesy of 'silkphoenix" on another post:

Windows Control Panel- Programs & Features (add/remove programs)-Skype Toolbars-uninstall... did it for me!!

read this: http://support.mozilla.com/en-US/questions/805438?s=%22Skype%22+%22extension%22+%22uninstall%22&as=s

Solution courtesy of 'silkphoenix" on another post: Windows Control Panel- Programs & Features (add/remove programs)-Skype Toolbars-uninstall... did it for me!! read this: http://support.mozilla.com/en-US/questions/805438?s=%22Skype%22+%22extension%22+%22uninstall%22&as=s
freebirdwil 0 solutions 7 answers

oops.. that link goes to this page... try this one!

https://support.mozilla.com/en-US/questions/820926?new=1

oops.. that link goes to this page... try this one! https://support.mozilla.com/en-US/questions/820926?new=1

Question owner

I thought I did mark the solution that helped, as you said?

I thought I did mark the solution that helped, as you said?
Kevin E 0 solutions 2 answers

Helpful Reply

If you got here because you searched for "remove skype button firefox" or some such thing and you don't want to remove the extension (just hide the gaudy button)... um... here's the official company line on that:

http://forum.skype.com/index.php?showtopic=633873

Skype says it will "take some time to implement" a toolbar button that can be removed. Like every other extension in existence that creates a toolbar button. I think they found a way to keep you from removing it, if you want to know the truth.

I didn't believe it for one second, so I started with these instructions for removing the orange Firefox button and added:

#skype_extension_v5_toolbar_button { display:none; }

to my "userChrome.css" instead of the stuff for the Firefox button. Restart Firefox and be gone, hideous and useless Skype button!

If you need to change the Skype extension's settings (which you should only need to set once, maybe unless you move/travel to a different country), you'll need to reverse the change or comment out that line in userChrome.css /* like this */, then restart Firefox again.

If you're really clever, you might be able to somehow make a user style and use Stylish to turn it on and off at will.

If you got here because you searched for "remove skype button firefox" or some such thing and you ''don't'' want to remove the extension (just hide the gaudy button)... um... here's the official company line on that: http://forum.skype.com/index.php?showtopic=633873 Skype says it will "take some time to implement" a toolbar button that can be removed. Like every other extension in existence that creates a toolbar button. I think they found a way to ''keep'' you from removing it, if you want to know the truth. I didn't believe it for one second, so I started with [http://downloadsquad.switched.com/2010/09/12/hide-or-move-the-orange-button-in-firefox-4-updated-2/ these instructions] for removing the orange Firefox button and added: <pre>#skype_extension_v5_toolbar_button { display:none; }</pre> to my "userChrome.css" instead of the stuff for the Firefox button. Restart Firefox and be gone, hideous and useless Skype button! If you need to change the Skype extension's settings (which you should only need to set once, maybe unless you move/travel to a different country), you'll need to reverse the change or comment out that line in userChrome.css <code>/* like this */</code>, then restart Firefox again. If you're really clever, you might be able to somehow make a [http://userstyles.org user style] and use [https://addons.mozilla.org/en-US/firefox/addon/stylish/ Stylish] to turn it on and off at will.

Modified by Kevin E