X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how to change the default search engine in the firefox 4 start page?

Posted

I upgraded to firefox 4 on my windows 7 computer and the home page was automatically set to the firefox 4 about:home start page. The search engine is automatically set to avg secure search. I want to set it to google(like the old home page) but I dont see an option to change it. I am aware I could just find the url for the old start page and use that but it would be nice to use the new one. anyone know how to change it?

07-15-2011 Locking this thread because it has gone off-topic. Please use Ask a new question and start your own thread. moderator

Modified by the-edmeister

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Unity Player 2.5.5b4

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

The Google search engine is hard coded for the about:home Home page. If you want to use another search engine then you need to change the Home page to another (search) page.

MacMuffin94 1 solutions 7 answers

I'm also having the problem, and the solution suggested doesn't apply.

The about:home page is not hard coded for Google, at least on my Firefox v4. It's Yahoo, and I too would like to change it to Google. I can't seem to find out how to change it either.

Question owner

dont say to change the keyword.url value either because that only changes the search provider in the address bar

Modified by zarkony

atekon 0 solutions 1 answers

ckeck trustnoone's answer here: http://support.mozilla.com/en-US/questions/769519#answer-137259

quoting: "If not I had to do this extra step where I had to reset these two things (search for them on filter: ) browser.startup.homepage_override.buildID

browser.startup.homepage_override.mstone "

I had the same problem and tried this. It worked!

kudos to trustnoone!

Question owner

I deleted all the leftover avg files and tried trustnoone's solution, but now it's using yahoo search, not google

MacMuffin94 1 solutions 7 answers

Just so it's easier, I'm gonna post a screen shot of what zarkony and I are talking about.

When we are at about:home, there's the search option on the page. After Zarkony deleted the AVG files, they are now in the same boat as me. That search goes to Yahoo. We want to set it to Google.

I've tried going through about:config but nothing seems to be about that default search option. What we're hoping is someone knows the solution to making that search, go to Google and not Yahoo, because Google is just all around better.


Is that clear enough? Or shall I explain more?

JorgeP 0 solutions 18 answers

1. The picture you show it's the default Firefox page search bar. 2. If the search goes to Yahoo, then make sure Firefox is your default browser. Tools>Options>Advanced>General tab>check to make Firefox default browser. 3. If you want the home page to be Google, go to google.com and make that your home page: Tools>Options>General tab>click Use Current Page to make that your home page. You don't have to config anything.

kelangela 0 solutions 1 answers

Helpful Reply

I just did this and it worked!

1. open firefox, type in “about:config” in the keyword box (address bar).

2. scroll down to “keyword.url”

3. right click on the URL and select “modify”

4. copy and paste one of google’s three ways of searching:


Google’s “I’m Feeling Lucky”: http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q=

  • default pre-Firefox 2.0 (this is the traditional Google search engine)

Google “Browse by Name”: http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=

  • Does not open Google's search engine at all...but goes directly to sites. (Limits searching ability I think)

Google Search (Google search results page): http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=



Modified by kelangela

Question owner

kelangela: I have already stated that the keyword.url value in the about:config page only changes the search engine in the address bar, NOT the start page

MacMuffin94 1 solutions 7 answers

Helpful Reply

JorgeP, we want to make the default firefox search google, not change the home page. It really should be something simple to change, but mozilla seems to have made it quite difficult. It's the first negative any version of Firefox has ever had, at least for me.

judyl68 0 solutions 2 answers

I also have this problem. I have always had Google as my default search engine, but now it has changed itself to Yahoo! I haven't even updated my Firefox browser from 3.6 as I read Firefox 4 is like Google Chrome (which is rubbish) and I liked it the way it was. I've always liked the fact that Mozilla let us personalise our browser but now I am being forced into having Yahoo as the default search engine. Its really annoying cos every time I want to search for something I have to change it manually to Google.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24386 answers

What's really annoying is people not reading what is posted in a thread and then posting an off-topic problem in the thread.

This thread is about the Firefox 4.0 about:home default homepage search engine getting changed by something that the user has installed.

If your problem isn't that, please start your own thread or post in a thread that is discussing you particular problem.


trustnoone may have the fix here - as atekon posted two weeks ago:
http://support.mozilla.com/en-US/questions/769519#answer-137259
browser.startup.homepage_override.buildID
browser.startup.homepage_override.mstone

Without knowing the value of what those two preferences were before he reset them, I can't even venture an opinion if that will fix the problem. I honestly don't see those prefs causing this particular problem, because their default values aren't URL's but rather numeric data relating to build date and the Gecko version number.

cojon 0 solutions 2 answers

I have a similar problem with Firefox 4. I cannot use Google as my default home page. Any attempt to use http://www.google.com as a home page arrives with http://www.google.com/search.php and a Google 404 error that says "This is an error, that's all it is"

i have been using Firefox forever it seems and I soundly appreciate the efforts of all who produce open source software. Now, however, it seems that as others, Firefox has decided to be lead by the nose by Yahoo, a "who cares about you, Ill put my butt in your face if you won't accept me on your own" company that will do ANYTHING to forge ahead--even complete deception. You see them everywhere attempting to become an advertizing toolbar, hoping you do not notice during an install because the notice of that is unobtrusive and small. They probably WILL get any many new users.

I, for one, have made a habit of COMPLETELY AVOIDING any company that places something in my face, on my computer, or attempts something somewhat deceptive to accomplish the same thing. Period! I will not visit them, I will not buy from them, I will not have any positive contact.

If everyone of us does that, there would be no commercial advertizing pop-ups or malware. If there was, their business profits would suffer and they would get the message. Sadly some corporations feel they must grab the whole pie even if it actually belongs to others. I will not use these companies. You should not either. This is what makes Americans into slaves.

If I must, I will give up Firefox as they have done the same underhanded thing. I understand, Yahoo, who's internet penetration was not deep enough because they were not first, has begun offering financial incentives to any greedy enough to take it. Thus we are forced to Yahoo, an extremely defective search engine by comparison, and a company that cares less about the individual--they just want to pile up enough suckers to bring them the king's crown, not earn it through excellence.

Please, Firefox et. al and all the contributing open source programmers, don't give in. Don't let your good reputation fall as Yahoo did. You do well on your own.

If I must, I can use Chrome. I would rather not however as it is comparatively inferior to the previous Firefox version. Please help me and others to remain loyal by your remaining being solid also.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

See also:

cojon 0 solutions 2 answers

I see I typed my message too rapidly, producing many errors. My apologies.

I was acting irrationally in my somewhat aggravated condition after realizing what had been done at Firefox to incorporate Yahoo and additionally make Yahoo difficult to avoid. New people to computing may not know or search for solutions, and many will be compromised by Yahoo. That's called forced advertising. It's like winning a baseball game by placing poison in the other teams mitts while their attention is diverted--say during the singing of our national anthem. Knowing it will slowly and deceptively leach into their skin, causing weakness and perhaps even an undesirable yet unavoidable dependency. You win, but not necessarily through excellence, but deception.

I mean what I said about Yahoo. I am simply apologizing to all who must stumble over my poorly worded, unrefined, unpolished work as it takes additional effort and I could (should) have done better. You certainly deserve better. Please insist upon excellence and an open, up front, deception free approach to computing. Did you pay $1000 to place someones free advertising into your home? If you do not actively resist these interlopers, your expensive machine could soon become a tool to change your thinking, and it could be through your conscious approval. Is that what you want?

Consider 1984 by George Orwell . . .
MacMuffin94 1 solutions 7 answers

Judy, we're talking about FF 4.0. It is like chrome, but it's better.

edmeister, it's not that it was changed to google, its that we want to change it to google from yahoo.

cojon, you're taking this way out of context, and way too radically. As far as I know, Google didn't renew it's contract for the default search engine or something like that. So Yahoo got it. It's not corruption, it's called business.

cor-el, your last answer has absolutely nothing to do with the problem at all.

EvanC0912 0 solutions 3 answers

Okay, I was dealing with this problem, too. Now, I've come up with the solution. My Firefox 4 Start Page is now using the Google search engine!

Follow these simple steps:

  1. Type "about:config" on the URL bar and press Enter. This will bring you to the browser's control panel.
  2. If a warning happens to show, just ignore it. Rest assured. We are not altering any major parts that will lead to failure. Therefore, just click the "I'll be careful, I promise!" button.
  3. You'll be brought to a page with various parameters and values of settings. To make it faster and easier, a filter bar is provided on the upper part of the window, just bellow the URL bar and Toolbars. Type "browser.search.order.1" on the Filter bar. Only 1 entry will now be listed. Reset the setting value (right-click > Reset). The value should now reset to "Google". If the value doesn't change to "Google", simply double-click the value and type it manually.
  4. Go back to the Filter bar and type "browser.search.defaultenginename". Again, reset the value so that it changes to "Google". If the value doesn't change to "Google", simply double-click the value and type it manually.
  5. It's done! Close the tab and you can try searching with Google on your Firefox 4 Start Page. The "Google" logo will now be shown to the left of the search text area.

I hope this guide solves your problem. Good luck!

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24386 answers

with all due respect EvanC0912,

This thread was started about the search engine that is used in the middle of the about:home default homepage in Firefox 4.0, and none of the prefs you mentioned have any impact upon that specific search container. The prefs you are talking about affect the Search Bar that is to the right of the Location Bar - not on the about:home "page" that is built into Firefox 4.0.

browser.search.defaultenginename is the Search engine that shows when you first start Firefox for each browsing session. browser.search.order.1, .2 & .3 are the order that the Search engines appear in the drop-down with which the user can select a different Search engine in the Search bar.

hitcola 0 solutions 1 answers

Hi all, I found a solution

1. in the address bar, type about:config, enter, accept the warning message.

2. reset any thing has "user set" attribute < that is because I don't know which one should be reset, so I reset every thing >

Note: to make it easy and quickly, sort the status column by clicking on the status word, this will gather all entries that has "user set" attribute, right click, then reset.

This should restore the Firefox settings to its defaults, don't worry it will not affect the bookmarks.

Thanks, Hitcola

Modified by hitcola