Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I upgraded to firefox 4 only to discover it no longer works with sxipper addon....is this going yo be resolved? and if not why?

more options

upgrade to firefox 4

Chosen solution

For the simple reason that the Sxipper is not supported on Firefox 4. Also, note that the Sxipper has been removed from the Firefox Addon page (you can't find it anywhere on Mozilla Firefox Addons web page).

I'm not sure if there would be a newer version of this wonderful plugin anymore - the latest release was done about an year back!

May be if all users signup here, something might happen - http://www.sxipper.com/sxipper3

Read this answer in context 👍 0

All Replies (7)

more options

Chosen Solution

For the simple reason that the Sxipper is not supported on Firefox 4. Also, note that the Sxipper has been removed from the Firefox Addon page (you can't find it anywhere on Mozilla Firefox Addons web page).

I'm not sure if there would be a newer version of this wonderful plugin anymore - the latest release was done about an year back!

May be if all users signup here, something might happen - http://www.sxipper.com/sxipper3

more options

An alternative to Sxipper maybe an addon called lastpass which is also free. I just did a cursory glance at Sxipper website and its function and I am sure lastpass can fullfill all or most of them.

https://addons.mozilla.org/en-US/firefox/addon/lastpass-password-manager/

If that is not to your liking, ou can also force Sxipper compatibility with Firefox 4, but that is not recommended.

more options

LastPass is what I'm using currently, all the way through Firefox 4 Beta. Though I'm quite uncomfortable in storing my passwords on some server.

more options

Thanks to all replies...I downgraded firefox back to v 3.x to continue using sxipper....it is an integral part of my daily use. thanks all

more options

I have just received notification that Sxipper will cease operations and they suggest to migrate. There willnot be a version for Firefox 4

more options

Xlalig... you've caught my attention---"can also force Sxipper compatibility with Firefox 4, but that is not recommended. " i love to crash and burn" ...

care to show me the force...???

more options

I have upgraded to firefox 4 and migrated to lastpass...all seems to be OK so far...thanks for all the help guys