X
Tap here to go to the mobile version of the site.

Support Forum

How do I set Firefox preferences to automatically open links in a new tab (just like Firefox3) ?

Posted

For example, when clicking on a link from a Google search, how can I have the link open automatically in a new tab as opposed to replacing the current page ?

For example, when clicking on a link from a Google search, how can I have the link open automatically in a new tab as opposed to replacing the current page ?

Chosen solution

Do you mean the Google search bar on the Navigation Toolbar or the search bar on the Google Home page ?

For the first you can set the pref browser.search.openintab to true on the about:config page.

For the Google website you can set your preferences on the Google.com page via the gear icon (click > Search settings) at the top right.


If you want to open all links in a new tab then you have to use an extension.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • iPhoto6
  • DivX Web Player version 1.4.1.4
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.2 r152

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

itsmeok 0 solutions 2 answers

Options, Tabs, Open new windows in a new tab

Options, Tabs, Open new windows in a new tab
cor-el
  • Top 10 Contributor
  • Moderator
12900 solutions 118327 answers

Chosen Solution

Do you mean the Google search bar on the Navigation Toolbar or the search bar on the Google Home page ?

For the first you can set the pref browser.search.openintab to true on the about:config page.

For the Google website you can set your preferences on the Google.com page via the gear icon (click > Search settings) at the top right.


If you want to open all links in a new tab then you have to use an extension.

Do you mean the Google search bar on the Navigation Toolbar or the search bar on the Google Home page ? For the first you can set the pref browser.search.openintab to true on the <b>about:config</b> page. * http://kb.mozillazine.org/about%3Aconfig For the Google website you can set your preferences on the Google.com page via the gear icon (click > [http://www.google.com/preferences?hl=en Search settings]) at the top right. ---- If you want to open all links in a new tab then you have to use an extension. *Tab Utilities: https://addons.mozilla.org/firefox/addon/tab-utilities/ *Tab Mix Plus: https://addons.mozilla.org/firefox/addon/tab-mix-plus/

Question owner

Thanks heaps. You've solved my problem ! Cheers, Ben

Thanks heaps. You've solved my problem ! Cheers, Ben
bnichols23 1 solutions 3 answers

Hey, cor-el -- long time no see! Hey, I have a problem, & my brain isn't working well enough to suss it out at the moment. :(

For some reason in the last week or so, links selected from either bookmarks or address bar no longer open automatically on selection, plus google search has disappeared from the nav toolbar . (Don't ask "what add-ons have you updated?" I don't know, & the add-on manager says I haven't done any recently.)

I checked about:config for browser.search.openintab; value is still set true. I toggled it false, restarted FF, then re-toggled true & another restart -- no joy. :(

I'm running 7.0.1 (release channel) on my work machine & the latest 8.x beta candidate at home; both exhibit the same behavior, so I'm assuming it's not a beta bug. What am I missing? I know it has to be something simple, but my brain refuses to compute. I know I could use safe mode & successively re-enable my add-ons, but I don't really have the time or mental clicks available.

I'm hoping it's something simple since I really don't have time to plod through everybloodydangthing for the one bad value that I'm sure is causing it. :/

Regards & Happy Monday!

Bill

Hey, cor-el -- long time no see! Hey, I have a problem, & my brain isn't working well enough to suss it out at the moment. :( For some reason in the last week or so, links selected from either bookmarks or address bar no longer open automatically on selection, plus google search has disappeared from the nav toolbar . (Don't ask "what add-ons have you updated?" I don't know, & the add-on manager says I haven't done any recently.) I checked about:config for browser.search.openintab; value is still set true. I toggled it false, restarted FF, then re-toggled true & another restart -- no joy. :( I'm running 7.0.1 (release channel) on my work machine & the latest 8.x beta candidate at home; both exhibit the same behavior, so I'm assuming it's not a beta bug. What am I missing? I know it has to be something simple, but my brain refuses to compute. I know I could use safe mode & successively re-enable my add-ons, but I don't really have the time or mental clicks available. I'm hoping it's something simple since I really don't have time to plod through everybloodydangthing for the one bad value that I'm sure is causing it. :/ Regards & Happy Monday! Bill
cor-el
  • Top 10 Contributor
  • Moderator
12900 solutions 118327 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history.


Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible: "View > Toolbars"

  • If items are missing then open the Customize window via "View > Toolbars > Customize" or via "Firefox > Options > Toolbar Layout"
  • If a missing item is in the toolbar palette then drag it back from the Customize window on the toolbar
  • If you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar set up.
Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.com/kb/Safe+Mode ---- A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.com/kb/Bookmarks+not+saved#w_places-database-file ----- Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible: "View > Toolbars" * If items are missing then open the Customize window via "View > Toolbars > Customize" or via "Firefox > Options > Toolbar Layout" * If a missing item is in the toolbar palette then drag it back from the Customize window on the toolbar * If you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar set up.