X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Just got message "something is preventing Firefox from updating securely" but I got Firefox 4 last week...?

Posted

It looks like Firefox tried to update my system, but couldn't; the message box then suggested upgrading to the latest version, but I just did...was this just a temporary glitch? Should I look for something? (btw, complete layman here...) Help! UPDATE 4/16: I kind of can't believe this has been up for weeks and still no replies; and I haven't been able to get chat assistance at the specified hours. Please don't make me ditch Firefox for IE...!!!

Modified by arejay

Additional System Details

This happened

A few times a week

This started when...

the box just popped up out of nowhere a few minutes ago; I'd already been online for a while, so I assume a new update was just issued...?

Installed Plug-ins

  • np-mswmp
  • 12.0.1.609
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.2 r153
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

rkjessop 0 solutions 1 answers

Don't hit the ok. Hit the "X" at the upper right. Then, go to the Help menu option and select "About". A message box will come up to tell you whether or not you need an update. I did this, and Firefox stated that my browser was up to date.

Question owner

Thanks for responding (you're the first in all this time!). But like you, my system's up to date, which means the message is either a bug or reflecting something else I can't identify. Wish I knew how to get a response from a super-tech; but thanks for trying, at least...

jsbiff 0 solutions 6 answers

Helpful Reply

I checked the Firefox Error Console (Tools > Error Console), and found this message repeated a couple times:

Error: Expected certificate attribute 'commonName' value incorrect, expected: 'aus3.mozilla.org', got: '*.mozilla.org'. Source File: resource://gre/modules/CertUtils.jsm Line: 60

It looks like someone, somewhere, made a mistake when setting up the Firefox auto-update security, so that it only trusts he server aus3.mozilla.org. I'd bet that for Firefox users not in Australia FF tries to connect to a different, local update server run by mozilla, which just doesn't happen to be aus3.mozilla.org, triggering this error.

Question owner

Thanks, jsbiff, that sounds plausible. (I didn't see that particular message in my Error Console, but I very recently had to do a restore so maybe it got wiped out.) I'm not a techie, so I'm just guessing that this'll keep happening until Mozilla makes a fix? But in the meantime I'm also guessing I can't get their updates, which I hope won't be a problem for those of us with this issue (I'm seriously disciplined wrt anti-virus/malware/etc)...? Thanks again for the response.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Helpful Reply

AUS stands for "Application Update Service" and has nothing to do with Australia

jsbiff 0 solutions 6 answers

Cor-el: Oh, my mistake. Still, it seems like, perhaps, the error is arising from a certificate error. It is possible that error in my console is unrelated to the popup, but the errors were the very last thing in the console right after that window popped up, so it seems likely to be related.

I wonder if anyone else getting this error can confirm that they are getting the same or similar errors? Or, perhaps, different errors altogether?

magbabe53 0 solutions 2 answers

to jsbiff: I just got the update error message a couple minutes ago, X'd it out, and went to the tools >error console> and have that same error message of Error: Expected certificate attribute 'commonName' value incorrect, expected: 'aus3.mozilla.org', got: '*.mozilla.org'. Source File: resource://gre/modules/CertUtils.jsm I have it several times, along with other error messages but there is no line:xx (number) I even tried calling my service provider like the message said to see if some kind of bug was coming through (I am non techie too) but they kind of just said "huh?" No help.....Comcast btw. Anyway, I have Trend Micro and Malaware and nothing bad seems to be happening so I am just for the time being ignoring it.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

See:

  • Bug 653830 - Popup notice Software Update - Update Failed - Something is trying to trick Firefox into accepting an insecure