X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

WebGL unavailable, recommends graphics driver update, but tried and udated graphics driver crashes system. Now what? Works fine on Google Chrome though.

Posted

WebGL demos don't work. "On the Help/Troubleshooting Information" it says: "WebGL Renderer(WebGL unavailable)"

It suggests upgrading my driver to the "version 257.21 or newer". I tried the latest driver from NVidia, but it crashes my system.

Chrome works fine though (e.g.

Modified by alepyro

Chosen solution

Sorry to hear that the newer driver crashes your system, but that is the problem that needs to get solved here. Try reporting to your computer manufacturer or to NVIDIA.

For what it's worth, Google Chrome's next version has adopted our blacklisting rule and is now also requiring NVIDIA 257.21 or newer: http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/software_rendering_list.json

Read this answer in context 3

Additional System Details

Sites Affected

http://bodybrowser.googlelabs.com/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Graphics
Adapter Description
NVIDIA Quadro FX 770M
Vendor ID
10de
Device ID
065c
Adapter RAM
512
Adapter Drivers
nvd3dum nvwgf2um,nvwgf2um
Driver Version
8.16.11.8992
Driver Date
5-12-2010
Direct2D Enabled
Blocked on your graphics driver. Try updating your graphics driver to version 257.21 or newer.
DirectWrite Enabled
false (7.0.6002.18409, font cache n/a)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
0/1

cz666 0 solutions 1 answers

Do you set "webgl.force_osmesa" to true in "about:config"? Set "webgl.force_osmesa" to false, set webgl.prefer-native-gl to true, and restart firefox try again.

My notebook is G 105M, I update to 266.58 driver and set "webgl.force_osmesa" to false , the firefox 4.0 and Minefield could run webGL

Modified by cz666

bjacob 2 solutions 11 answers

Chosen Solution

Sorry to hear that the newer driver crashes your system, but that is the problem that needs to get solved here. Try reporting to your computer manufacturer or to NVIDIA.

For what it's worth, Google Chrome's next version has adopted our blacklisting rule and is now also requiring NVIDIA 257.21 or newer: http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/software_rendering_list.json

Question owner

Managed to get the latest driver from nVidia installed, thanks to support from Dell. Just needed the latest chipset drivers from Dell so that there were no conflicts with the nVidia driver.

WebGL working now :-)

cuong1104 0 solutions 1 answers

''# chữ nghiêng''