X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to get rid of an error message?

Posted

I downloaded the new Firefoxy4, and each time I open it I get a message window that says: Type Error:Components.classes[@mozilla.org/extension/manager:1] is undefined. and asks to press the OK button. When pressed Firefox 4 opens. How do I get rid of the error message?

Chosen solution

This is probably due to an add-on that is not compatible with Firefox 4. For details of how to troubleshoot that see https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Shockwave Flash 10.2 r153
  • iTunes Detector Plug-in
  • Garmin Communicator Plug-In 2.8.3.0
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Live Update v1.5
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

This is probably due to an add-on that is not compatible with Firefox 4. For details of how to troubleshoot that see https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

Question owner

Thanks TonyE That worked a treat. Cheers Lawandra