Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why doesn't Firefox 4.0's Back Button doesn't work from home page or google search?

  • 5 replies
  • 117 have this problem
  • 113 views
  • Last reply by morongoff

more options

I just upgraded to firefox 4.0 tonight, and the back button isn't working correctly from my home page or from certain types of google searches.

I can reproduce this problem every time by doing the following:

1) Open a new tab, and I get a blank page. 2) Select the Home button. I end up at http://www.google.com/ig 3) Go to the address bar and type in a new URI, and hit return

I now leave my home page and go to the new page, but I cannot go back to my home page.

Similar behavior happens if I do a google search from the quick search addres in the upper right hand corner.

1) start a new tab. 2) Enter a search term and hit enter 3) click on one of the search links, and you transition to the new page, but the back button doesn't work.

It works fine if I do something like: 1) Open a new tab. 2) Enter google.com in the address bar and hit enter. 3) Do a search from GOOGLES search arae. 4) Click a search result link.

This works fine for me.

Chosen solution

In my case, I disable the McAfee SiteAdvisor 3.3.1 add-on, and the problem goes away.

Read this answer in context 👍 6

All Replies (5)

more options

Chosen Solution

In my case, I disable the McAfee SiteAdvisor 3.3.1 add-on, and the problem goes away.

more options

Thank you! That solved it for me too!

more options

I don't wanna claim total credit for it. I remember seeing someone mentioned a Back button problem with McAfee Add-on in the forum. I dismissed it initially because it seems far-fetched...

more options

OhmaiGosh... McAfee sucks at life again!

~ thanks risnub, would've never tried that without reading about it!

Modified by bananapeal

more options

In my case, it stopped working after I installed Greasemonkey...uninstalling Greasemonkey and restarting FF-4 fixed the back-button issue.