X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox does not open with my home page

Posted

Whatever settings I use (eg Options>Options>General>Show my Home Page), Firefox opens with the page(s) from my last session. I'd quite like my home page back!

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • npsharedview
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Live Update v1.5
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

johnnylinux 0 solutions 2 answers

I had this problem as well, but was able to solve it using this procedure:

- Close firefox from the menu (don't use the 'x' as firefox may continue to run in memory for a while)

- in your start menu, enter the following into the "run" prompt: firefox.exe -P

- The firefox profile manager will open (see attached image)

- In my case I deleted the "default" profile because I didn't care about losing any settings. You may want to simply create a new profile instead in case you need to save your settings.

- To avoid being asked about which profile to be used you can highlight your new profile and then make sure the "Don't ask at startup" checkbox. When ready, press the "Start Firefox" button.

- Voila! That fixed it for me. Like I said, I just created a new "default" profile and everyone worked fine for me; use your own judgement here.

Good luck!