Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not open on MacOSX v. 10.4.11. AT all. What should I do?

  • 4 replies
  • 42 have this problem
  • 13 views
  • Last reply by lacuskey

more options

Downloaded new FF4 and it could not run on Mac OSX v 10.4.11. It just crashes.

All Replies (4)

more options

I'm using FF 3.6.16, very recent update, on a G5 PowerMac running up-to-date Mac OSX 10.4.11. This afternoon (my time here) I opened FF 3.6.16 and was offered update to FF 4, which I tried, unsuccessfully, to load and run. Here's what happened. After downloading and clicking on the .dmg, the usual FF icon and look-like Applications icon appeared side-by-side. But the FF icon had a "no go" sign planted over it. Sliding the FF icon onto the Applications one gave a message indicating 3.6.16 is more recent than the version the icon-slide would give. So I opted out. I wondered whether I was victim of a web-site forgery. I think maybe 'Mozilla' have taken-down FF 4 for the time being, attending to reported bugs (pls. see other forum posts about them), or FF 4 isn't suitable (yet) for anything earlier than Mac OSX 10.5. Am I right, please? Thanks & cheers. Mb.

more options

Sorry, should've added to my post a couple of min's. back that when, after my problem, I went and checked for available updates in 3.6.16's 'Help > Check for Updates' pull-down, the response was 'No Updates Found .... There are no updates available. Firefox will check periodically for updates'. Tks. & cheers agn. Mb.

more options

I encountered the same problem as previous two questions. Luckily, I save older ff 3.16.6 so I am able to get into this forum. Trying to use new ff4 I get message error: "You cannot use the application "Firefox" with this version of Mac OS X"

Why did I get an email to update to the new ff4?

more options

I also received the same email to update to ff4 After installed, tried to use and error msg said my Mac OS-X did not support ff4? I was able to save prev. version, and get into this forum.

Was ff4 a scam, possibly have keystroke app.? I dumped ff4 immediately!

unable to get response from mozilla, anybody know how to confirm ff4 is what it is?