X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Magic Trackpad Pinch and Zoom Gestures Not Working

Posted

With the Apple Magic Trackpad, Firefox 4 does not work Pinch and Zoom. In 3.6 no problems just 4.0

Additional System Details

This happened

Every time Firefox opened

This started when...

Downloaded/using FF 4.0

Installed Plug-ins

  • iPhoto6
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 4.0.51204.0
  • Shockwave Flash 10.2 r152
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

astrobill 0 solutions 5 answers

Yeah...I had this happen today on my MacBook Air today when updating from Firefox 3 to 4.

I fixed it by following the instructions for editing the Firefox about:config preferences as described in the following post, which shows they had this problem in the last release candidate version of Firefox but (apparently) didn't fix it.

Luckily, the fix seems to have "taken" for me and was saved in my Firefox preferences so I don't have to keep doing the fix:

https://support.mozilla.com/en-US/questions/781509

Modified by astrobill

quondamprolix 0 solutions 1 answers

I have a trackpad with my desktop computer at work; the "fix" (as suggested here: http://forums.whirlpool.net.au/archive/1671426) did not work for me. The easy zoom functions was one of the reasons I got the trackpad; I'm switching to Chrome until a fix is found.

Question owner

Still using Safari until this issue is corrected. Sorry. Seems so easy to see that this is an ongoing issue until fixed. DO IT ,please. Thanks

kmombo 0 solutions 2 answers

alright so why did firefox release this shit version? i did all the about:config stuff and have re-checked the settings over and over again and it's still not working. so i tried to download firefox 3.6 and now that also isn't working. looks like i'll be back to using safari from now on..this is bullshit.

webserf 0 solutions 13 answers

Helpful Reply

This worked for me.. I had this problem with my browser as well. I'm using OS X 10.6.8 but, Try this: type the following into the address bar: about:config Then use the filter (top left side) and type the word, Gesture. Make the following changes to the following 2 fields: browser.gesture.pinch.in ~ enter the field and type, cmd_fullZoomReduce browser.gesture.pinch.out ~ enter the field and type, cmd_fullZoomEnlarge

These changes should immediately restore the pinch gestures you are used to. Try it as soon as you make the changes and let us know. I've included a screenshot.

Note the changes in the 2 lines and make them. This worked for me. Good luck.

Question owner

Yes, Firefox current version (5.whatever) is already outdated. You folks at Mozilla just can not keep up but still release browsers like betas all the time. Reminds me of old Microsoft: if nobody complains don't fix it. I'm complaining. Firefox used to be my default browser and really liked all the features and addons. I had completely done away with Safari, Opera, etc for FF. That is until the pretty (and useless) 4.0. What good is it if the features that are built into modern browsers as a foundation such as mouse and trackpad gestures are completely missed by Mozilla? Hello? Apple? Magic TrackPad? Got a pulse, FF? So, Google Chrome is looking kind of good and so is Opera. Why would I want to use a half-baked, beta software even free? One last thing found today: "Chrome supported a three-fingered swipe to the right or left on a Mac trackpad to move forward or backward, respectively, through previously-viewed pages. Lion, however, seized that gesture and assigned it as the command to move between full-screen applications, another new feature of OS X 10.7." Nuff said.

Question owner

Still not supporting Magic Trackpad, eh? Then still no update to FF 6.whatever. You guys with your fast-track updates are just trying to keep up with the Google's! Seriously, why not just say this is v4.2? Numbers don't count - quality does! Thanks, Mozilla.

Question owner

One more thing... When Apple effectively gets rid of the mouse, what will you do then? Why should I go into config: to add anything to make what should work - work? Me: still using FF 4 something but Safari is still preferred browser.

gregeric 0 solutions 1 answers

Helpful Reply

Fixed. Type the following into the address bar: about:config Then use the filter (top left side) and type the word, Gesture. Make the following changes to the following 2 fields: browser.gesture.pinch.in ~ enter the field and type, cmd_fullZoomReduce browser.gesture.pinch.out ~ enter the field and type, cmd_fullZoomEnlarge

Trackpad1 0 solutions 2 answers

This is bizarre. I've tried the about:config route (10.6.8) and now the Zoom In works - but not the Zoom Out.

Why anyone would think disabling the trackpad feature is a good idea and constitutes an "upgrade" is beyond me.

Please fix!

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can restore the zoom feature by changing the values of the related prefs on the about:config page.

  • browser.gesture.pinch.in -> cmd_fullZoomReduce
  • browser.gesture.pinch.in.shift -> cmd_fullZoomReset
  • browser.gesture.pinch.out -> cmd_fullZoomEnlarge
  • browser.gesture.pinch.out.shift -> cmd_fullZoomReset
  • browser.gesture.pinch.latched -> false

See also:

Trackpad1 0 solutions 2 answers

O K A Y! - I changed all 5 settings and now it works properly.

Many, Many Thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You're welcome