X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Youtube does not work on firefox anymore, it works on Internet Explorer but on firefox the videos wont load. I tried safe mode so that isn't it and i tried reinstalling flash player. Any suggestions?

Posted

When i click on a video it just stays black and it doesnt load. I dont know if this will help but when i right click it it says movie not loaded and about adobe flash player.

Additional System Details

Sites Affected

http://www.youtube.com

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Motive Plugin for Mozilla Browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

squid 0 solutions 3 answers

Helpful Reply

I was having the same problem - I saw another thread here about it tried what they suggested and it worked. Try adding an s to the http in the address. https instead of http.

Question owner

Actually its really weird but a while after I posted this YouTube just randomly started working as if nothing happened. I didn't do anything so I don't know what happened.

1fotomojo 0 solutions 1 answers

Wow! That does work! Why does this happen?

wschick 0 solutions 2 answers

Helpful Reply

I disabled adblock and videos now show

alan_r 58 solutions 753 answers

Time to update to at least Fx3.6.17 for security reasons.