Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open URLs in outlook 2010 email. Works OK when IE is default browser. URL opens properly when I paste it into FF.

  • 6 replies
  • 63 have this problem
  • 6 views
  • Last reply by shar0nct

more options

Running Win 7, Outlook 2010 and FF 3.6.15. I used to have no problem clicking URLs in Outlook messages, but now, when FF is default browser, I get message: "General Failure. The url was: "http://.....". An error occurred sending the command to the application." Link opens OK if I copy url to FF. Also works when IE is default browser.

All Replies (6)

more options

Workaround...

From http://www.pcworld.com/article/200103/fix_outlook_general_failure_error_for_email_links.html:

Hassle-Free PC Fix Outlook 'General Failure' Error for E-Mail Links

By Rick Broida, PCWorld Jun 29, 2010 12:45 PM

(Note: These instructions apply to Windows Vista and 7 only.)

1. Click Start, type regedit, and then press Enter.

2. Navigate to the following entry: HKEY_CLASSES_ROOT\FirefoxURL\shell\open\ddeexec

3. In the center pane, double-click the Default entry, then remove whatever value is there (it'll probably be a weird string of numbers and commas).

4. Click OK, then exit Regedit.

5. If Outlook and/or Firefox are open, close them, then restart them.

more options

Thanks for the help, but for some reason that I don't understand, the problem has disappeared. i have now upgraded to 3.6.16, but I think the probem went away before this.

more options

When I eliminated the values, and tried to open the link, it caused Firefox to crash instead of giving me the error message that it could not load the page. This problem seemed to occur when I upgraded Firefox 5.0. I am using Windows 7, Outlook 2010. Begrudgingly, I make IE Explorer the default, and the links now work fine. I will have to sit by while a solution is arrived at.

more options

Every single time that I have to do an update on Firefox I then have to go back into the regedit and follow the directions again in order to prevent this error. The issue should be corrected by Mozilla on their next update. To be honest, it is kind of annoying!! This has been an issue for several months, and I am tired of having to fix their mistakes! MOZILLA!!! PLEASE FIX THIS ISSUE!!!

I HAVE ATTACHED A SCREEN SHOT OF THE ERROR THAT I AM GETTING.

more options

I've solved the problem by changing to Chrome. I found that the latest release of Firefox kept crashing and I don't have the time to dig around to solve their problems. I may come back to FF when there is a new release.

more options

Work around did not work for me as there was NO string of characters in HKEY_CLASSES_ROOT\FirefoxURL\shell\open\ddeexec