Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After updating to Firefox 3614, I cannot view videos on youtube itself.

  • 38 replies
  • 162 have this problem
  • 209 views
  • Last reply by jernejster

more options

I can hear sound on youtube itself, but not seeing any video, yet youtube works on other sites.

Modified by psb51

All Replies (20)

more options

It appears to be a Flash problem which is also affecting Chrome.

You can still see, when you hover your cursor over the place where the button to play the video in the "Pop-out" box should be at the lower edge of the video screen, the exact location of that button. Left-click on that location and the video will come up in the "Pop-out" box.

Obviously a work-around and not a cure, but better than nothing.

more options

Coigach, thanks for the workaround, I wouldn't mind it too much, except I can't see the "pop-out" button, either. I tried clicking it and most times got "full screen" mode, which also didn't play. When I did get the pop-up to work, it worked, but it was difficult to find when it couldn't be seen!

more options

Problem solved, and you don't have to remove deactivate Hardware accelerator. Simply go to your cookies and remove your old youtube cookies, and it should work! However, I should also add that you should block all cookies from youtube, otherwise you have to remove cookies every time you go to the site.

Modified by psb51

more options

Thanks for the workaround, psb51!

I don't consider this a "solution", by any means, but it's the first viable workaound I've seen, yet!

I wonder why this happens at all?

more options

On second thought, not such a good workaround.

I can view videos, but I can't SIGN IN to youtube, as a result, so I can't view favorites, save videos or post comments.

So, the search for a solution, continues.

more options

Luckily, I don't have a youtube account, so I don't have that problem, but I was afraid that would be the case for others. Try allowing cookies for session in your Firefox options and see what happens. And if you find a fix, let me know. Totally annoying.

more options

A little practice will soon find the right spot to click.

However, I've now found that for me an update of the drivers for the video card has solved the problem completely :-)

more options

I would do that if I could remember how to find the damn video card so I can update it.

more options

The "session" cookie permission works about as well as I might have guessed; namely, it works for the first video of the session and I remain signed in, until I start a new session, where I am logged out and get ONE more video.


Video drivers would be great but I have the latest ones made for my laptop and there is not likely to be an update.

The problem is a FireFox / Youtube / Flash one and I sure hope they fix it, since this "update" screwed it up.

more options

You could reinstall Firefox 3.16.13 to fix the problem until Mozilla releases a fix for it. Link via Mozilla's ftp servers:ftp://ftp.mozilla.org/pub/firefox/releases/3.6.13/win32/en-US/

more options

Thanks. I spent hours trying to find that. Except the FTP won't let me download it. Keep getting permission denied.

Modified by psb51

more options

I'm having this problem as well I've found that disabling the shockwave plugin then reloading the page so it displays the "no flash found" then enabling it + refreshing will show the video but this is tedious to do on every video I want to watch

I cant find that "Pop-out" button

more options

I have a problem with youtube videos and Firefox 3.6.14 update. I have four machines and this problem is only apparent on two of them. These two machines are older.

I turned off hardware acceleration on the flash player.

Run a video....right click on it to bring up a menu. Select settings and the monitor icon. Uncheck hardware acceleration.

Deleting the cookies also works for the next video...but this is not a great solution.

I have no idea why this happened only after updating firefox.

Post back here if this works.

See if this works for you even if you have a newer machine.

more options

Modified by Efreak101

more options

Thanks, I decided to go with unclicking hardware acceleration which seems to work for now.

more options

Turning off Hardware acceleration has worked for me

more options

My dear people this is frustrating. Today after upgradin flash player Youtube stopped working. It has to be something connected with flash player.

However, for some reason that I don't really know, I also have that safari browser and seem to be working OK on Youtube.

Can anyone figure out the solution for Firefox, because I just love this browser.

All the settings i have are default and the problem started oafter upgrading flash player, so message to Adobe team: "Get serious people!"

more options

@jernejster This is a problem with Firefox 3.6.14. Update to the latest version, pronto. (Firefox 3.6.15) The easiest way is via the Help menu. Help>Check for Updates. This should fix your problem.

Modified by Efreak101

more options

Already done so, no changes...

I've checked all the updates and even the online application monitor on firefox support page. Everything seems to be of the latest version. Now I hae the 3.6.15 version of FF and I've also uninstalled flash and reinstalled it and still no changes. Help menu couldn't find any more updates.

Still stucked in safari watching sexy ladies in some mac software - no good for me...

more options

Hmm, It must be something wrong with your flash player...

  1. 1
  2. 2