X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do I delete "My Web Search" toolbar that just appeared and where did it come from?

Posted

how do I delete "My Web Search" toolbar that just appeared and where did it come from?

Chosen solution

You have an item installed that is considered malware/spyware/adware. To see the Plugins reported with your question, click "More system details..." to the right of your original question or, on the Firefox menu, click Tools > Add-ons > Plugins.

  • My Web Search Plugin Stub for 32-bit Windows

This type of pest is usually installed along with software you download from the internet; generally free programs, but not always. Carefully watch for "extra" items that will be installed and un-check or opt-out of them.

  1. You can check to see if you have any of these from Web Products" installed:
  2. Also see: http://kb.mozillazine.org/Uninstalling_toolbars
  3. You MAY need to change a preference if when typing one or two words in the URL/Location/Address Bar sends you to some search page other than the one you expect. To reset your default URL/location bar search provider:
    • Enter about:config in the address/URL bar and press the Enter key
    • If you see a warning, accept it (Promise that you will be careful)
    • Filter = keyword.URL
    • Below the Filter, if keyword.URL is bold, right-click on keyword.URL and choose "Reset"
    • Restart Firefox (File > Restart Firefox)
    • See: http://kb.mozillazine.org/Keyword.url
  4. You MAY need to reset your homepage if some search page that you do not want or expect opens when you start Firefox. Firefox can open multiple home pages. Home pages are separated by the "|" symbol.



Other issues needing your attention

The information submitted with your question indicates that you have out of date plugins with known security and stability issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post. You can also see your plugins from the Firefox menu, Tools > Add-ons > Plugins.

  • Adobe Shockwave for Director Netscape plug-in, version 10.1
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.6
  • Shockwave Flash 10.1 r102
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
      • Use the links below to avoid getting the troublesome "getplus" Adobe Download Manager and other "extras" you may not want
      • Use Firefox to download and SAVE the installer to your hard drive from the appropriate link below
      • Click "Save to File"; save to your Desktop (so you can find it)
      • After download completes, close Firefox
      • Click the installer you just downloaded and allow the install to continue
        • Note: Vista and Win7 users may need to right-click the installer and choose "Run as Administrator"
      • Download link: ftp://ftp.adobe.com/pub/adobe/reader/
        • Choose your OS
        • Choose the latest #.x version (example 9.x, for version 9)
        • Choose the highest number version listed
          • NOTE: 10.x is the new Adobe Reader X (Windows and Mac only as of this posting)
        • Choose your language
        • Download the file, SAVE it to your hard drive, when complete, close Firefox, click on the installer you just downloaded and let it install.
        • Windows: choose the .exe file; Mac: choose the .dmg file
    • Using either of the links below will force you to install the "getPlus" Adobe Download Manager. Also be sure to uncheck the McAfee Scanner if you do not want the link forcibly installed on your desktop
    • After the installation, start Firefox and check your version again.
  4. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.
  5. Update the Java plugin to the latest version.
Read this answer in context 22

Additional System Details

This happened

Just once or twice

This started when...

just now when i opened Firefox, never before

Installed Plug-ins

  • Adobe Shockwave for Director Netscape plug-in, version 10.1
  • Office Plugin for Netscape Navigator
  • 6.0.12.1662
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.6
  • Shockwave Flash 10.1 r102
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • My Web Search Plugin Stub for 32-bit Windows
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)

More Information

Noir 0 solutions 2 answers

Go to "Tools"-> Add ons and search for the matching entry. Now uninstall it.

Question owner

Following your suggestion, within "Tools"-> Add ons, I didn't see a way to actually uninstall it. The choices were "Disable" or "Enable". I disabled it. Is there actually a method of uninstalling this add-on? Do you know where it came from? If I were to delete Firefox entirely and reinstall it, would this add-on be gone? I have an extensive bookmarking system with with thirty folders on the bookmark line and absolutely must not take any chances of loosing the bookmarks and their organization.

Helper7677 165 solutions 1653 answers

Chosen Solution

You have an item installed that is considered malware/spyware/adware. To see the Plugins reported with your question, click "More system details..." to the right of your original question or, on the Firefox menu, click Tools > Add-ons > Plugins.

  • My Web Search Plugin Stub for 32-bit Windows

This type of pest is usually installed along with software you download from the internet; generally free programs, but not always. Carefully watch for "extra" items that will be installed and un-check or opt-out of them.

  1. You can check to see if you have any of these from Web Products" installed:
  2. Also see: http://kb.mozillazine.org/Uninstalling_toolbars
  3. You MAY need to change a preference if when typing one or two words in the URL/Location/Address Bar sends you to some search page other than the one you expect. To reset your default URL/location bar search provider:
    • Enter about:config in the address/URL bar and press the Enter key
    • If you see a warning, accept it (Promise that you will be careful)
    • Filter = keyword.URL
    • Below the Filter, if keyword.URL is bold, right-click on keyword.URL and choose "Reset"
    • Restart Firefox (File > Restart Firefox)
    • See: http://kb.mozillazine.org/Keyword.url
  4. You MAY need to reset your homepage if some search page that you do not want or expect opens when you start Firefox. Firefox can open multiple home pages. Home pages are separated by the "|" symbol.



Other issues needing your attention

The information submitted with your question indicates that you have out of date plugins with known security and stability issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post. You can also see your plugins from the Firefox menu, Tools > Add-ons > Plugins.

  • Adobe Shockwave for Director Netscape plug-in, version 10.1
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.6
  • Shockwave Flash 10.1 r102
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Shockwave for Director
    • NOTE: this is not the same as Shockwave Flash; this installs the Shockwave Player.
    • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below (Desktop is a good place so you can find it).
    • When the download is complete, exit Firefox (File > Exit)
    • locate and double-click in the installer you just downloaded, let the install complete.
    • Restart Firefox and check your plugins again.
    • Download link and more information: http://support.mozilla.com/en-US/kb/Using+the+Shockwave+plugin+with+Firefox
  3. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
      • Use the links below to avoid getting the troublesome "getplus" Adobe Download Manager and other "extras" you may not want
      • Use Firefox to download and SAVE the installer to your hard drive from the appropriate link below
      • Click "Save to File"; save to your Desktop (so you can find it)
      • After download completes, close Firefox
      • Click the installer you just downloaded and allow the install to continue
        • Note: Vista and Win7 users may need to right-click the installer and choose "Run as Administrator"
      • Download link: ftp://ftp.adobe.com/pub/adobe/reader/
        • Choose your OS
        • Choose the latest #.x version (example 9.x, for version 9)
        • Choose the highest number version listed
          • NOTE: 10.x is the new Adobe Reader X (Windows and Mac only as of this posting)
        • Choose your language
        • Download the file, SAVE it to your hard drive, when complete, close Firefox, click on the installer you just downloaded and let it install.
        • Windows: choose the .exe file; Mac: choose the .dmg file
    • Using either of the links below will force you to install the "getPlus" Adobe Download Manager. Also be sure to uncheck the McAfee Scanner if you do not want the link forcibly installed on your desktop
    • After the installation, start Firefox and check your version again.
  4. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.
  5. Update the Java plugin to the latest version.

Modified by Helper7677

Question owner

I went to my the Firefox menu, Tools > Add-ons > Plugins and found "My Web Search Plugin Stub for 32-bit Windows" and disabled it (not deleted yet). I then went to Control Panel > Add or Remove Programs, and found "My Web Search Bar" and removed it (subject to a later restart). I usually only browse commercial business websites and didn't immediately realize where I could have downloaded and installed this nuisance toolbar from. It was from "123 Print Cards.com" when I downloaded a Valentines Day card. The site provided no notice, warning or advisement of this toolbar delivery with the card. I suppose there isn't any protocol that requires web sites to disclose this kind of not-approved add-on. Thank you all, problem solved.

MayorSirWippet 0 solutions 1 answers

I had the same problem, but the search engine was part of Cursormania.com's installation, and I thought it was a little fishy with the way it works. Thanks heaps for the query and all reply's they've been a great help! :)

Modified by MayorSirWippet

gus_69 0 solutions 1 answers

Pls. refer to the article in the link below - I was also infected by this malware "My Web Search" which got installed without my knowledge and got it removed by following the steps mentioned in the article. Specifically, would like to quote the method below which worked for me.

"I was beginning to get frustrated at this point and suddenly another “test idea” came across my mind. I went to the configuration mode of Firefox by typing “about:config” on the location bar. But searching for “defaultSearch” in the filter bar, gave me “Google” as the default engine! Damn. Where did they hide the redirect hijack configuration then? Baffled, I now keyed in “myweb” in the filter box and here it was. It showed me the entries where the user setting was modified to hijack the browser, without my permission. I right-clicked both the entries, choose “Reset” and restarted Firefox. Hurray! And now the search result is back to Google. I am glad that this nasty hijack episode is finally over for me"

http://software-testing-zone.blogspot.com/2009/08/fix-mywebsearch-hijacked-firefox.html