X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Not able to install .xpi file in firefox

Posted

I have created my first addon and it is working fine in dynamic mode (pointer in profiles folder to development folder). Then I created the .xpi file by compressing entire content as .zip and replacing it with .xpi. I tried to installed this. Firefox does not install the addon neither it give any error. Firefox shows the regular warning while installing the addons and ask for restart and then it restarts automatically but addon is not installed. When I go back and see the profiles directory I do not see the folder for new addon where as reset of the existing addons are there.

Also, when I decompress the .xpi file and manually created the folder in extensions folder for the addon the addon works prefectly fine.

I checked the error log but nothing there. Below is the link to addon I am struggling with. Any help would be great.

https://addons.mozilla.org/en-US/firefox/addon/format-javascript/

Thanks in advance

Chosen solution

All files are in the root folder of that archive. You didn't move the files to folders, but added the directory path to the file. I see this file name defaults\preferences\prefs.js

You will have to create a proper directory structure in that archive and move each files to the correct directory.

Read this answer in context 1

Additional System Details

Application

  • User Agent:

More Information

dynamite 60 solutions 382 answers

This forum is for answering questions about using Firefox. For getting help on add-on development and troubleshooting, you should post your query in the add-on development support forum: https://forums.mozilla.org/addons/viewforum.php?f=7

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Chosen Solution

All files are in the root folder of that archive. You didn't move the files to folders, but added the directory path to the file. I see this file name defaults\preferences\prefs.js

You will have to create a proper directory structure in that archive and move each files to the correct directory.

Helpful Reply

Thanks cor-el for the input.

Looks like there was something wrong with my zipping utility. I changed it and now the addon works fine.

thanks for your help

dynamite - thanks for your advice too.

Appreciate the help!

antonioaraujob 0 solutions 1 answers

Dear vimu.patel, I had the same problem you posted. Following your post and cor-el answer I could install a .xpi file I have been developing successfully; my zip file was not created correctly.

Thanks