X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Youtube videos are blank black screen only on my firefox browser.

Posted

I can't play any youtube videos on my firefox. All my programs are update to date. Also youtube videos are working for my internet explorer but not on my firefox. I have the latest version 3.6.13

I'm on a PC 32 bit home basic vista.

Modified by helpthisgame

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
Read this answer in context 18

Additional System Details

Sites Affected

http://youtube.com

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • LogMeIn, Inc. Remote Access Components
  • np-mswmp
  • ijji Web Launching Plugin for FireFox
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.1 r102
  • DivX Web Player version 2.0.3.4
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.51204.0
  • Office Live Update v1.3
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Version 0.9.18, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • Version 1.1.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.13) Gecko/20101203 BTRS30790 Firefox/3.6.13 ( .NET CLR 3.5.30729)

More Information

I can't play any youtube videos on my firefox. All my programs are update to date. Also youtube videos are working for my internet explorer but not on my firefox.

ToniVC 0 solutions 2 answers

I have exactly the same problem: first youtube video works ok, but when I try to view another one I only get a black video, with no controls. Only sound sometimes works... Any idea????

Modified by ToniVC

ToniVC 0 solutions 2 answers

This is a sample of what I get.

Modified by ToniVC

letheaqua 0 solutions 4 answers

A youtube or Firefox bug. Delete all cookies from youtube cookies first > open firefox tools> options> privacy> firefox will: choose in drop down box:use custom settings for history>

show cookies> delete youtube cookies

in box:accept cookies from sites> choose exceptions> add:http://www.youtube.com> click ok at bottom. Firefox will no longer accept cookies from youtube.

This is a temporary until bug is fixed.

Modified by letheaqua

letheaqua 0 solutions 4 answers

This worked for me

Modified by letheaqua

Coigach 0 solutions 15 answers

It appears to be a Flash problem which is also affecting Chrome.

You can still see, when you hover your cursor over the place where the button to play the video in the "Pop-out" box should be at the lower edge of the video screen, the exact location of that button. Left-click on that location and the video will come up in the "Pop-out" box.

Obviously a work-around and not a cure, but better than nothing.

RonQ 0 solutions 80 answers

Cor-el, problem is, this problem seems to affect many of us WITHOUT themes installed.

RonQ 0 solutions 80 answers

TonyE, running with disabled hardware acceleration is not an acceptable solution for many of us.

RonQ 0 solutions 80 answers

Flushing cookies worked for a while, but the problem came right back after I viewed one more youtube video.

So flushing cookies is not a permanent solution.

NOTE: blocking the youtube cookies allows me to view more than one video, BUT, it won't let me sign on, so I don't have access to any of my own videos or upload anything.

Modified by RonQ

lucymaxy 0 solutions 1 answers

I've just had this problem since i installed the new version of firefox. i found that my problem was there was an update needed for 'No Script', as soon as i installed the update by going to Tools>Add-ons>Extensions>Find Updates, my videos played absolutely fine again. Hope this helps.

mancalledhero 0 solutions 1 answers

I had this problem too. I noticed that it happened after I installed the latest Adobe Flash Player 10.2, so I uninstalled it and installed the older 10.1 and the problem is gone. It's worth a shot.

EDIT: Using Firefox 3.6.15

Modified by mancalledhero

50sVintage 0 solutions 2 answers

The situation is outrageous.

Firefox did an automatic update & left me with black blank youtube screens although the audio remains perfect.

I emptied cookies & cache and the visual came back to youtube.

Next morning Firefox did another automatic update and again left me with black, blank youtube screen.

Firefox left me in the predicament where I have to re-sign in to more than a dozen sites where I constantly do business online.

Firefox - what is up with you? The infliction of this bug is atrocious. WILL YOU FIX IT ALREADY??

Alex 0 solutions 1 answers

guys,to fix that problem,just go to start button den run den type dxdiag den click ok-->now click the display tab den disable the DirectDraw Acceleration den restart ur firefox browser.thats all

Hope This Helps You!

sorry for mah poor english guys X)

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

emolex,

Depending on the Windows system, some people may not be able to use your suggestion. Ref: http://www.sevenforums.com/graphic-cards/10311-cannot-disable-directdraw-d3d-acceleration.html
Even so, using dxdiag to disable DirectDraw hardware acceleration in your computer might be overkill. Ref: http://technet.microsoft.com/en-us/library/cc938991.aspx
Quote:
Lack of hardware acceleration. Some programs run slowly or not at all unless DirectDraw or Direct3D hardware acceleration is available. On the Display page, under DirectX Features, check whether DirectDraw, Direct3D, or AGP Support is marked Not available. If so, consider upgrading your hardware.

I would try TonyE's suggestion to disable Hardware acceleration in Flash settings first (Right-click on any Flash video, click "Settings", select the Display tab and uncheck “Enable hardware acceleration"). For those people using Firefox 4 Beta, you can also try disabling hardware acceleration in Firefox, in the Advanced settings for accessibility, browsing, system defaults, network, updates, and encryption General Tab, by removing the checkbox from the setting, "Use hardware acceleration when available" and then r4starting Firefox (Screenshot). If it doesn't help, set it back.

Art67 0 solutions 2 answers

I started getting a blank white screen plus audio on Youtube about a week ago.

To compare notes with others who share the problem:

  • On other sites, such as Vimeo, Google video and Dailymotion, videos play fine.
  • Embedded Youtube videos in e.g. Facebook, are fine, both video and audio work.
  • I DO HAVE the same problem on Chrome and Opera.
  • I DON'T HAVE this problem on Internet Explorer.
  • The fix that Adobe suggests, i.e. disabling Hardware Acceleration in Flash settings when you right-click the Youtube (blank!) screen doesn't work, as the 'Settings' option is no longer available.
  • I've tried disabling an re-enabling every extension I have, including Flashblock, Adblock Plus, Webmail Adblocker, and it had no effect whatsoever on the problem. However, I did not completely uninstall any of those.

I've also submitted a report to Youtube, and I'd suggest that everyone who encounters the problem does the same, in case somebody, somewhere takes notice...

poopipants 0 solutions 1 answers

I had the same issue and I had to go into options and blocked the cookies for youtube.com , and that did the trick. Go to tools, click options click on privacy click the drop down menu "firefox will" and select: use custom settings for History under accept cookies from sites, click exemptions, a window will open, type youtube.com and click block. and you are set. I know there is something that is causing the trouble but until the bug is found this will do the trick. good luck

eaujmp 0 solutions 1 answers

Thanks for that info....did the trick for me & was super-easy!!  :-)

stakeouttoo 0 solutions 3 answers

letheaqua.... thanx much... followed your instructions after I tried a lot of different solutions.. yours w*rked... thanx again.. appreciate it  :)

Modified by stakeouttoo

2chrispy 0 solutions 2 answers

I'm having the same problem...very annoying !!! Help me...

2chrispy 0 solutions 2 answers

Thank you sooo much, it worked.

mcharest22 0 solutions 1 answers

This is working, only problem, you can't sign in anymore when you block youtube cookies.