Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No matter how I try to change it, the comcast sign-in page always comes up as my home page.

  • 4 replies
  • 16 have this problem
  • 6 views
  • Last reply by al66888

more options

Although I have repeatedly tried to change my home page, whenever Firefox restarts it always reverts to the Comcast sign-in page and never remembers my opened tabs.

Also, when I click on "Start Private Browsing", nothing happens.

I've tried starting in Firefox safe mode, disabled all my addons, but still Firefox restarts with the Comcast sign-in home page and no tabs from the previous session.

Although I have repeatedly tried to change my home page, whenever Firefox restarts it always reverts to the Comcast sign-in page and never remembers my opened tabs. Also, when I click on "Start Private Browsing", nothing happens. I've tried starting in Firefox safe mode, disabled all my addons, but still Firefox restarts with the Comcast sign-in home page and no tabs from the previous session.

All Replies (4)

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Safe mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Your above posted system details show multiple Java Console extensions. You can uninstall (remove) the Java Console extensions, you do not need them to run Java applets.

See http://kb.mozillazine.org/Java#Multiple_Java_Console_extensions

more options

Thanks Cor-el for your response. I followed your instructions (including the uninstallation of all the Java Console extensions) and still cannot keep the home page from starting with the Comcast sign in page. I used the "Set Default Home Page" which is Mozilla but Comcast overrides that both in Firefox Safe Mode as well as normal mode.

With all addons disabled it still reverts to the Comcast sign-in page. I also set the default theme and that too reverts to a non-default theme when I restart Firefox.

If you have any other suggestions, they would be greatly appreciated.

more options

I found this after nothing else worked, followed the steps and deleted the user.js and it worked. Apparently when you add Comcast/Xfinity services and are forced to download their pack, they place a script in there that hijacks your home page. I had this problem, and installed xfinity toolbar which I said no to, and it hijacked my search as well.

Anyone know if that's legal? Seems like the textbook definition of malware. Here's the article from some guys blog, Ryan Parman. Instructions are simple enough for anyone to follow. Here's the link, this worked for me:

http://blog.ryanparman.com/2011/07/07/remove-comcastxfinity-start-page-from-firefox-mac/