X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

"Warn me when closing multiple tabs" doesn't work

Posted

Under Tools > Options > Tabs, "Warn me when closing multiple tabs" is selected. Also, in about:config, browser.tabs.warnOnClose is set to "true". I always have multiple tabs open. However, sometimes my hand slips or the mouse falls off the table and Firefox closes without any warning.

Chosen solution

The original problem was getting Firefox not to close when the X was accidentally clicked. The Fast Close Tabs addon is a work-around, but it's pretty much solved the problem: https://addons.mozilla.org/en-US/firefox/addon/fast-close-tabs/

This addon changes the function of the X to close a single tab rather than the entire window. Mind you, it would still be nice if core Firefox actually did what the options said it did, or at least if the options were reworded to reflect what they actually do. But the Fast Close Tabs addon is a good enough alternative.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Version 1.7.1.0
  • Google Talk Plugin Video Accelerator version:0.1.43.4
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Default Plug-in
  • Google Update
  • Unity Player 2.6.1f3
  • Shockwave Flash 10.1 r102
  • DivX Web Player version 2.0.3.4
  • GEPlugin
  • 4.0.50917.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

Application Basics
Name
Firefox
Version
3.6.13
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Cookie Whitelist, With Buttons
1.0.3
true
cwwb@dietrich.cx
FaviconizeTab
1.0.1
true
faviconizetab@espion.just-size.jp
Image Zoom
0.4.4
true
{1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}
NoScript
2.0.8.1
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
TabCounter
1.0.3
true
tabcounter@felipc.com
InFormEnter
0.5.5.9
true
{5546F97E-11A5-46b0-9082-32AD74AAA920}
Tiny Menu
2.0.2
true
{d33c2f7c-b1e6-4d46-ab0e-be1f6d05c904}
ChromaTabs Plus
2.3
true
{1cff04ef-0c75-4621-ba2a-2efb77346996}
Bookmarks menu
1.3
true
bookmarks-menu@dio.gr
Remove New Tab Button
1.0
true
remove-new-tab-button@forerunnerdesigns.com
Greasemonkey
0.8.20100408.6
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Menu Editor
1.2.6
true
{EDA7B1D7-F793-4e03-B074-E6F303317FB0}
Organize Status Bar
0.6.4
true
{35106bca-6c78-48c7-ac28-56df30b51d2c}
IdentFavIcon
0.3.2
true
identfavicon@david.hanak.hu
TagSieve
4.2.8
true
tagsieve@grue.in
Firebug
1.6.0
true
firebug@software.joehewitt.com
SwiftTabs
0.3.6.8
true
{5F4EC95A-FFA8-11DE-898C-667D55D89593}
Hide Tabbar
0.7.3
true
{7EE8902C-75BE-4286-A6CE-0C483607A322}
Echofon
1.9.7.3
true
twitternotifier@naan.net
Split Browser
0.6.2009110501
true
{29c4afe1-db19-4298-8785-fcc94d1d6c1d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
14
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:1.9.2.13
browser.tabs.insertRelatedAfterCurrent
false
browser.tabs.loadFolderAndReplace
false
browser.tabs.maxOpenBeforeWarn
5
dom.disable_window_move_resize
true
dom.disable_window_open_feature.close
true
dom.disable_window_open_feature.minimizable
true
dom.disable_window_open_feature.scrollbars
true
dom.event.contextmenu.enabled
false
dom.popup_maximum
2
extensions.lastAppVersion
3.6.13
font.default.x-western
sans-serif
font.name.serif.x-western
Book Antiqua
network.cookie.cookieBehavior
2
network.cookie.lifetimePolicy
2
network.cookie.prefsMigrated
true
network.http.pipelining
true
network.http.pipelining.maxrequests
8
network.http.pipelining.ssl
true
network.http.proxy.pipelining
true
network.prefetch-next
false
places.last_vacuum
1289800633
print.print_printer
Microsoft XPS Document Writer
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_pagedelay
500
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11.00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8.50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1.00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Application Basics
Name
Firefox
Version
3.6.13
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Cookie Whitelist, With Buttons
1.0.3
true
cwwb@dietrich.cx
FaviconizeTab
1.0.1
true
faviconizetab@espion.just-size.jp
Image Zoom
0.4.4
true
{1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}
NoScript
2.0.8.1
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
TabCounter
1.0.3
true
tabcounter@felipc.com
InFormEnter
0.5.5.9
true
{5546F97E-11A5-46b0-9082-32AD74AAA920}
Tiny Menu
2.0.2
true
{d33c2f7c-b1e6-4d46-ab0e-be1f6d05c904}
ChromaTabs Plus
2.3
true
{1cff04ef-0c75-4621-ba2a-2efb77346996}
Bookmarks menu
1.3
true
bookmarks-menu@dio.gr
Remove New Tab Button
1.0
true
remove-new-tab-button@forerunnerdesigns.com
Greasemonkey
0.8.20100408.6
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Menu Editor
1.2.6
true
{EDA7B1D7-F793-4e03-B074-E6F303317FB0}
Organize Status Bar
0.6.4
true
{35106bca-6c78-48c7-ac28-56df30b51d2c}
IdentFavIcon
0.3.2
true
identfavicon@david.hanak.hu
TagSieve
4.2.8
true
tagsieve@grue.in
Firebug
1.6.0
true
firebug@software.joehewitt.com
SwiftTabs
0.3.6.8
true
{5F4EC95A-FFA8-11DE-898C-667D55D89593}
Hide Tabbar
0.7.3
true
{7EE8902C-75BE-4286-A6CE-0C483607A322}
Echofon
1.9.7.3
true
twitternotifier@naan.net
Split Browser
0.6.2009110501
true
{29c4afe1-db19-4298-8785-fcc94d1d6c1d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
14
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:1.9.2.13
browser.tabs.insertRelatedAfterCurrent
false
browser.tabs.loadFolderAndReplace
false
browser.tabs.maxOpenBeforeWarn
5
dom.disable_window_move_resize
true
dom.disable_window_open_feature.close
true
dom.disable_window_open_feature.minimizable
true
dom.disable_window_open_feature.scrollbars
true
dom.event.contextmenu.enabled
false
dom.popup_maximum
2
extensions.lastAppVersion
3.6.13
font.default.x-western
sans-serif
font.name.serif.x-western
Book Antiqua
network.cookie.cookieBehavior
2
network.cookie.lifetimePolicy
2
network.cookie.prefsMigrated
true
network.http.pipelining
true
network.http.pipelining.maxrequests
8
network.http.pipelining.ssl
true
network.http.proxy.pipelining
true
network.prefetch-next
false
places.last_vacuum
1289800633
print.print_printer
Microsoft XPS Document Writer
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_pagedelay
500
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11.00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8.50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1.00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97009 answers

You can try to keep another window open like the Bookmarks Manager (Library) or Download Manager.

In Firefox 3 you do not get the 'Save & Quit' pop-up dialog if you choose Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time".

However session restore works more reliable if that setting (Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time") is selected.

Question owner

The problem is that I always have 20+ tabs open, and quite frequently have 50+ tabs open when I'm working. When Firefox closes, I first must wait for it to close completely after the window is gone (or I get the message saying that Firefox is already running), then load it again and wait for all my tabs to reload, which can take some time and is annoying.

I have selected "Show my windows and tabs from last time" since I've already seen that system restore is not entirely reliable without it.

Is there a way to ask confirmation when closing, so that Firefox does not close accidentally, yet still reliably restore my open tabs after I have purposefully closed and reopened Firefox?

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97009 answers

Which keys do you press by accident to close Firefox? It is possible to disable shortcut keys (except Alt+F3) that close Firefox with an extension like Keyconfig.

On Linux there is Ctrl+Q to close the browser. So if you want to press Ctrl+W to close a tab and instead press Ctrl+Q then you close the browser.

Question owner

I'm running Windows 7 on a laptop with an external mouse (I strongly dislike trackpads). If the external mouse slides off my desk, or if I'm not careful while moving the laptop, the mouse pointer tends to slide to the upper right corner, where a small bump counts as a click and closes Firefox. I only rarely use keyboard shortcuts, so I don't think I've accidentally closed Firefox that way.

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97009 answers

That close X will close the window. To prevent closing the browser you could open an extra window like I wrote above, but that will still require to restore that closed window. If it really only happens when you move the mouse to the top right then you can make the window slightly smaller just enough to prevent clicking that close button or you can work full screen without a title bar.

See also Autohide: http://www.krickelkrackel.de/autohide/

Question owner

Yeah, the real problem is the time it takes to reload the tabs I have open. So keeping open another window doesn't do very much. I was really hoping for a way to get the "Warn me when closing multiple tabs" option to do what it says on the tin, but if that's not possible, I guess I'll just live with it.

dr.ilangho 0 solutions 4 answers

'THIS WORKS !!!' I am a doctor.But here is my help:

Please got to this link & read my answer again: with inputs from helper 1677

https://support.mozilla.com/en-US/questions/801965#answer-176156

helper 1677, b`cos I had done what he had said even before seeing his input:so, i do no know if my suggestion alone worked OR all did.but the problem is solved. On the Mozilla home page http://www.mozilla.org/ type this:about:config And enter despite a warning box"I`ll be careful,I promise":-) Just tick it & enter.


Change the column: "browser startup page" -userset integer- from 3 to 4 by double-clicking on that link & changing 3 to 4 !

browser.startup.page;4

This idea I got from this link below.

http://www.mydigitallife.info/firefox-3-doesnt-prompt-or-warn-to-confirm-when-closing-multiple-tabs-as-warning-not-working/

Reply if it works by signing in;as others will be helped !

THIS WORKS !!!

Rahul_D 0 solutions 1 answers

Sol 1) Go to options-->Tabs: check option "Warn me when closing multiple tabs" Sol 2) When we select option "Never remember history" or "Use custom setting for history" in Privacy tab then Firefox dont warn when closing multile tabs. If you want Firefox to pop up a box warning that you are closing multiple tabs and also not to remember history,password,etc. then do as suggested in below picture(Click to maximize it), it work definately. Thanks.

Modified by Rahul_D

Question owner

The problem with Rahul_D's response is that the original problem has nothing to do with browser history. The problem is that since Firefox 3 (so for the last 7 major versions now), the option "Warn me when closing multiple tabs" simply has not done what it claims to do. It's a fundamental programming error that we're supposed to believe is a feature because Mozilla's programmers are too incompetent to have an option actually do what it says it will do.

The problem with dr.ilangho's response is that browser.startup.page must be set to 3 in order to reload your tabs from the previous session when you start a new session. The original problem was that it was inconvenient to have to reload all my pages after closing. Changing the browser.startup.page value to anything but 3 means those pages won't reload at all, and any work on them is lost completely. That's hardly an improvement.

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97009 answers

See:

ifasmile 0 solutions 3 answers

I had this problem too a few monthes ago, sorry don't remember how I solved the problem...

BUT a general TIP is that you sometimes should fully reinstall Firefox from the scratch.

I mean save your bookmarks (json), have a list of your add-ons, preferably with their url too, and one for your plugins too, everything safe in a folder in your documents...

And only then "shoot away" Firefox from your computer, profile included... make a full cleaning of everything belonging to Firefox. (with Glary utilitises, CC cleaner or any soft alike)

Reinstall everything with the latest Firefox.exe !

This especially if you're used to ( as I am) try new adds, make changes in about:config... and so on.

I guess it comes because with the "normal way of updating", which I suppose is the case for most people, just to download the updates, Firefox, after a few monthes, starts to mess a little things around.

And even "Speedyfox" nor defragmentation can't help that much...

Personnaly, I don't like so much to do it, but like that, usually my Firefox works fast and well.

Another solution is to use "FEBE" add-on...

I wish this "general tip" will help some of you, or at least give some indications, on how you want to solve some Firefox problems :-)

Note : depending on how many add-ons you have, this may take ~30minutes up to 3 hours (:-(), if you have never saved anything before (list from your adds).

PS Me ? I save everything quiet often, because I once lost, years ago, everything concerning Firefox because I did a main mistake (lost all my bookmarks)... and told myself : Not Twice... :-)

Happy Christmas ! :-)

Chosen Solution

The original problem was getting Firefox not to close when the X was accidentally clicked. The Fast Close Tabs addon is a work-around, but it's pretty much solved the problem: https://addons.mozilla.org/en-US/firefox/addon/fast-close-tabs/

This addon changes the function of the X to close a single tab rather than the entire window. Mind you, it would still be nice if core Firefox actually did what the options said it did, or at least if the options were reworded to reflect what they actually do. But the Fast Close Tabs addon is a good enough alternative.

SamuraiFoochs 0 solutions 6 answers

I just started having this problem last night. I have the "Automatically Restore Previous Session" option enabled, but it still used to warn me before. It's not a big deal or anything, it's merely unsettling why the change has occurred and I don't know why. I hate the unknown! Haha.