X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox freezes when loading sites and opening tabs

Posted

My Firefox often freezes when I'm trying to open a site in one tab or several. The freezing lasts for a couple of seconds but its really frustrating.

The version is the latest stable (3.6.13) I've tried re-installing the browser, but the broblem persists.

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
Read this answer in context 8

Additional System Details

This happened

Every time Firefox opened

This started when...

Opening new websites in one tab or several.

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Foxit Reader Plug-In For Firefox and Netscape
  • Default Plug-in
  • Unity Player 3.0.0f6
  • Shockwave Flash 10.1 r102
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.51204.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; fi; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

Frejm 0 solutions 26 answers

Update: Tried FF5 and FF6 Aurora latest build, no luck. Disabled all addons. Firefox even freezes when I click "check to see if your plugins are up to date" on the addons page... Or when loading Twitter in new tab... this is getting so frustrating.

Koying 0 solutions 2 answers

I had this problem, too. My solution was to recreate a new profile. Apparently, the profile became corrupted (or bloated) along the years...

See here (http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows ) to try with a new profile.

Just be sure to save your bookmarks somehow.

Frejm 0 solutions 26 answers

Nope new profile did not help either.

Frejm 0 solutions 26 answers

Reporting same problem on Aurora 7 latest update (11/7/2011)

Alpha_Link 0 solutions 1 answers

Yep, even to this day with the latest update, still having this issue. Come on, Mozilla! This has been going on for how many months now and still no solution? I'll be switching over to Chrome shortly...

Modified by Alpha_Link

dougtaylor 0 solutions 1 answers

Thanks Koying for the tip on recreating the profile (http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows) . I recreated my profile and no problems so far. I haven't loaded all of my plugins yet, but since Firefox was freezing even starting it with add ins disabled, this is at least a step in the right direction.

Modified by dougtaylor

Frejm 0 solutions 26 answers

Well I give up. No update on this matter whatsoever and I keep running both UX, Aurora and newest stable Firefox version constantly. I'm on the edge to move away from ff now.

mtravis390 0 solutions 2 answers

I've just given up on Firefox 6.o being fixed. It easier to uninstall it and reinstall 5.0 Problem is then fixed.

Frejm 0 solutions 26 answers

And same issue on 7.0

Jayden 0 solutions 7 answers

That's a fine sounding solution, but the problem is this happens every few hours, so you can't disable add-ons for hours at a time when you're using Firefox as a serious development tool.

Is there any way to look at a log when the hang occurs? Or perhaps force quit firefox during the hang, and then look for the log??

Jayden 0 solutions 7 answers

Same here... issue hasn't changed after upgrading to 7.0.1

Jayden 0 solutions 7 answers

Ok - going to try creating a new profile and will see if the issue persists over the next few days....

But wait - that's for windows. I'm on a mac... damn. Will still try it out.

Modified by Jayden

aarwdc 0 solutions 2 answers

wrong place

Modified by aarwdc

aarwdc 0 solutions 2 answers

IT WORKED!! I got rid of Norton Web Safe, and it solved a problem I have had across 2 computers and many versions of FF. THANK YOU

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

The default of the pref network.http.max-connections has been increased from 30 to 256 in Firefox 6+ versions.

You can try to decrease the value of the pref network.http.max-connections from 255 to a more modest setting like 30 as used in Firefox 3 versions.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

gman620 0 solutions 1 answers

I have Kaspersky Internet Security 2011, and when disabled the problem still remains after opening a couple of tabs the browser freezes, i disabled all of the addons and i have rested everything, and the problem still remains, you just have to solve this

morshem 0 solutions 1 answers

In the last couple of days I had the same problem. I tried creating a new profile and work there from scratch. In the beginning it worked smoothly without hangs. Then in the options I set an address in Networking -> Automatic proxy configuration URL. After I did that suddenly this annoying freezing returned. I then removed the address from there and set it back to the default option (system settings), and since then the browser works fine again.

So far it seems fine, so that might be a possible solution.

Modified by morshem

Tatane 0 solutions 1 answers

Hi everyone, well I've the same damn problem...upgrading and from 6 to 7 version of FF and still no luck.

I think this is a mayor that simple bug, because I'm running ArchLinux and the output en safe-mode show no error so far, and this is not a operative system issue.

So, I'm sorry mozilla but I'm going for chromium, this could not happen to my favorite browser...

nalbancis 0 solutions 1 answers

having this problem this few weeks....but hey pals did you ever change the "about:config" settings on your firefox browser. so if you Ive got a fix for that...maybe try to remove/reset the "ng.initialpaintdelay integer"..it might fix the problem..

just give it a try. It works for me.

Modified by nalbancis

Silichip 0 solutions 3 answers

I've had two problem with my Windows 7 x64 from freezing on my Pc and had no other choice but to press the restart button ??? However I have a solution...

First problem was installing the new hardware driver version 4.3.790.0 for the Nvidia 8 series graphic card (GeForce 8500 GT) and to solve it, I needed to go to Nvidia Control Panel then to "Adjust image settings with preview" and select "Use my preference emphasising", since my Acer P205H LCD monitor is a 2D and not a 3D model screen...

Second problem from freezing my Pc when I installed the new Firefox version 12.0 browser and to solve that issue was go to Tools, Options, Advanced, General tab and un-tick "Use hardware acceleration when available" box... Now I have no problems with my Pc from freezing and all working fine and hope this maybe helpful to someone here. Good luck!

P.S. If you are still having problems with Firefox and all else has failed then I just created a portable version, so there no need to install the software and it works on both x32 & x64 Windows... Now you will need to completely remove all of the Firefox installation files and also use a register cleaner and delete any remaining files from the hard drive directory...

Here you will need to go to organize folder option and select show hidden files!

C:\Users\Name\AppData\Local\ & C:\Users\Name\AppData\Roaming\

So all you need to do next is download my portable version at 'http://j.mp/firefoxport' then place this Mozilla folder to "C:\Program Files\" HD directory and create a shortcut of the 'firefox.exe' file and added it to your desktop and pin it to taskbar or start program menu...

Modified by Silichip