Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get a message popup saying unable to update because I do not have system permissions required when trying to go to 3.6.13 on my IMac,but I am the system administrator.

  • 5 replies
  • 20 have this problem
  • 5 views
  • Last reply by tazman1949

more options

I tried updating from 3.6.12 to 3.6.13 on my IMac and get a pop up window that says Unable to update because I do not have system permissions required to update. If I download the latest version and try to replace the existing version it says "The operation can’t be completed because you don’t have permission to access some of the items." I called Apple and made sure I was the system administrator and I am. I made sure that the two other users did not have FireFox open and it still fails the same way.

Note: This problem resolved itself for some reason but I still want to thank everyone for their suggestions.

Modified by tazman1949

All Replies (5)

more options
  • Download a new copy of the Firefox program: http://www.mozilla.com/firefox/all.html
  • Trash the current Firefox application to do a clean (re)install.
  • Install the new version that you have downloaded.

Your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks and other personal data.

more options

OK, I think I have a solution to the problem, DOWNLOAD, NOT UPDATE, Firefox 3.6.13 from their website. Then run the Firefox setup, when it's done extracting, click next, then click Custom setup. When it ask where do you want to install the Firefox Program, DON'T USE THE DEFAULT FILE PATH, instead click browse and put in "My Documents" or "Desktop". I would suggest you create a folder in "My Documents" or "Desktop" and install the program in there. After that step click any shortcuts you would like to make EXCEPT the START MENU PROGRAMS FOLDER. After this step, click next, then install.......

This is my Christmas present unto the world!!!.........

P.S. - I just can't believe you "adults" couldn't figure it out..... I'm only 14.......

more options

Oh, I didn't know, Cor-el, already answered this post, sorry man.......

more options

That is only hiding your problem (you lost your house key and decide to build a new house...) and not a real solution. You would need to repair the file and folder permissions to fix such an issue, but trashing is a much quicker way to deal with it.

more options

After trying several times to install 3.6.13, I tried looking at my Quest log on and found the download data on the desktop. I dragged the icon over to Applications and it worked. I went back to my sign on and sure enough it worked there as well. I still don't know why but it works and that is good enough for me. Thanks to all that sent suggestions on to correct the problem.