X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Plugin Check says "Outdated Version" (Shockwave Flash), but latest already installed

Posted

Problem: latest Flashplayer installed, but:

Plugin Check: https://www.mozilla.com/en-US/plugincheck/

says "Shockwave Flash Shockwave Flash 10.1 r102" - "Outdated Version"

ok, I try

1. "rm ~/.mozilla/plugins/libflashplayer.so" - get rid of Flashplayer

2. restart Firefox

3. check Plugins - no Shockwave Flash (rm worked)

4. download Linux (tar.gz or deb) Flashplayer from http://get.adobe.com/de/flashplayer/

5. unpack downloaded file

6. "cp libflashplayer.so ~/.mozilla/plugins/"

7. reboot

8. run Firefox Plugin Check (Shockwave Flash is there)

-> result: again: "Shockwave Flash Shockwave Flash 10.1 r102" & "Outdated Version"

How can it be?

Modified by rkat

Additional System Details

Installed Plug-ins

NoScript (disabled for mozilla Plugin Check) Firebug

Application

  • User Agent:

More Information

abehrens 0 solutions 3 answers

Symptoms are the same, although in my case the plugin was installed as an rpm (flash-plugin-10.1.102.65-release.i386), and the plugin is found in /usr/lib/mozilla/plugins/libflashplayer.so -> /usr/lib/flash-plugin/libflashplayer.so.

Question owner

Maybe important: I use the Firefox binary from Mozilla.com. (Not Firefox from Ubuntu.) When I do a "locate libflashplayer.so", only the file ~/.mozilla/plugins/libflashplayer.so is listed.

Question owner

After update to libflashplayer.so version 10.2.152.0 (available now), the Plugin Check says "Up to Date"! So, this solved the problem for me (for now).

Question owner

2011-05-15: again... after installing current from http://get.adobe.com/de/flashplayer/ which says (latest) version is "10.3.181.14". After restart of Firefox:

"about:plugins" says flashplayer version is "10.3 r181".

http://www.mozilla.com/en-US/plugincheck/ says installed flashplayer is "Outdated Version" and version is "10.3 r181".

I would really like to understand what is going wrong.

  • Does flashplayer give the wrong version to Firefox?
  • Does Firefox give the wrong version to the plugin-check page?
  • Is there a problem with the plugin-check page?
  • What can I do to solve the problem?

Modified by rkat

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96700 answers

If you have the latest version of the Flash player then you can ignore that.

I see the same on Linux.

Question owner

Obviously some component of the Mozilla/Firefox plugin-check is unable to get/transfer the complete version-string of Adobe flashplayer.

Here are the facts of todays checks:

after upgrading:

I guess the check will work again when there is a version like "10.3.184.x". If you read about the security problems of flashplayer, this might be way too late.

Conclusion: if you want to have the most recent flashplayer all the time, you have to check the version manually. You can do so at http://www.adobe.com/software/flash/about .

[Edit: inserted a space after the links, so the : is not part of the link.]

Modified by rkat

James
  • Top 25 Contributor
  • Moderator
437 solutions 3146 answers

Helpful Reply

The http://www.mozilla.com/en-US/plugincheck/ is manually updated as it can sometimes take a few days to be updated when say a new Flash version is released.

Question owner

Just re-installed "10,3,183,5" (checked version at http://www.adobe.com/software/flash/about ,disabled all plugins like no-script, better privacy). https://www.mozilla.org/de/plugincheck/ says: "10.3.183.0", "up to date".

I think the Mozilla Firefox plugin check does not get or check the minor version ".5" or ".10". It prints ".0" all the time!

Maybe it's a feature or a problem that prevents the transmission of that minor number (except to adobe.com?!).