X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I unblock profile photos on Facebook? They are visible with Explorer, but not with Firefox.

Posted

When using Firefox, my Facebook profile photos are no longer visible, but I can see them on Internet Explorer. How do I change the settings to unblock my photos?

Chosen solution

With Facebook on display, click on the site identity button (for details on what that is see the How do I tell if my connection to a website is secure? article) and then on More Information. This will open up the page info dialog.

First select the Permissions panel, make sure that "Load Images" is set to allow (selecting Use Default should also work)

Next select the Media panel, then click on the first item in the list. Use the down arrow key to scroll through the list. If any item has the option "Block images from (domain name)" selected, de-select the option.

This should hopefully resolve your issue, but also see Fix problems that cause images to not show.

Some add-ons can also block images, for example if you have AdBlock Plus installed, make sure that you have not accidentally created a filter to block the images.

Read this answer in context 32

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r102
  • Office Plugin for Netscape Navigator
  • npunagi2
  • Coupons, Inc. Coupon Printer DLL
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 6.0.11.847
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

With Facebook on display, click on the site identity button (for details on what that is see the How do I tell if my connection to a website is secure? article) and then on More Information. This will open up the page info dialog.

First select the Permissions panel, make sure that "Load Images" is set to allow (selecting Use Default should also work)

Next select the Media panel, then click on the first item in the list. Use the down arrow key to scroll through the list. If any item has the option "Block images from (domain name)" selected, de-select the option.

This should hopefully resolve your issue, but also see Fix problems that cause images to not show.

Some add-ons can also block images, for example if you have AdBlock Plus installed, make sure that you have not accidentally created a filter to block the images.

Question owner

TonyE,

You are the best!!! It was the blocked images under the media panel that was causing the problem. You ROCK!!! Life is good again. Thanks so much for taking the time to help me!

Denise

dicky100 0 solutions 4 answers

Helpful Reply

i have a brother. when i opened my daily website. my brother block my daily website how to unblock it?

dicky100 0 solutions 4 answers

i have a brother. when i was opening my dailny website. my brother block it.. so how to unblock it?