Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Gmail - Compose email - Command-left/right shortcut not working

  • 9 replies
  • 141 have this problem
  • Last reply by EGep84

more options

Firefox 3.6.12 Mac OS X 10.5.8

In the 'Compose mail' window of GMail the shortcut Command-left arrow or Command-right arrow to jump to respectively beginning or end of a line, is not working. Command-up/down (go to top/bottom) and option-left/right (jump per word) are all working fine. I already tried running Firefox in Safe mode but still the same issue. Also tried clearing the cache and all history but to no avail. In Safari the shortcut works fine but I'd like to stick to Firefox.

Thanks for any suggestions.

Chosen solution

Despite being marked as "solved" I'm on Firefox 10.0.1 and this is still a problem. Also wanted to mention a similar key combination command-delete. In any other application this deletes everything between the cursor and the beginning of the current line.

Read this answer in context 👍 2

All Replies (9)

more options


I know no one has posted any suggestions, but have you had any luck resolving this on your own yet? I have the same Gmail issue as you, and am experiencing it in Hotmail as well.

At first I thought it was a Firebug extension issue, because of what I read here:

And although those suggestions fixed the problem for some people, and the threads / support tickets appear to have been closed -- none of those things worked for me.

I never realized how much I use those keyboard shortcuts until this started happening. And because I rely on Gmail for work, this is getting to the point where I may need to go back to Safari -- which I really don't want to do.

Can anyone at Mozilla comment on this? Even if it's just to say that you're aware of it / are working on it?

Modified by gatorfantom

more options


Unfortunately still no solution until now. I was hoping that some of the recent Firefox updates would contain a fix, but nothing yet. I try to manage using the alt-arrow left/right to jump per word. The strange thing is that the cmd-arrow left/right does work in the subject field or to-field. So it really only is in the compose-window.

Let me know if you find something.

more options

Okay... After spending a good 7-8 hours researching this I ended up with a 3-page document of possible causes, potential fixes, similar issues on different sites/platforms, notes, and dozens of links to supporting forum posts and bug reports. Although this post says that only 33 people have reported having the same issue (as of 4/17/11), it's actually a lot more widespread. I found some comments on other sites that dated back to 2005, and there are at least four other posts on this site alone relating to a similar issue. (I wish there were a way to tie them all together.) There are dozens of threads about this topic on other forums/sites, and lots of good info -- but none that seem to put all the pieces together. So this is an attempt to do just that.

Below are some of the main takeaways of what I found, which I've phrased in sort of a Q&A-type format. If we're lucky, maybe this post will start getting more traffic — and more "I have this problem too" clicks. (Assuming that triggers some kind of an alarm at Mozilla once it reaches a certain number?)


-In most applications, the following are default/standard shortcuts:

  • Command + Left Arrow = move text insertion point to the beginning of the current line
  • Command + Right Arrow = move text insertion point to the end of the current line

-These shortcuts DO NOT work in the Firefox (browser) + Gmail (webmail editor) environment


-Which app is the source of the issue?

  • The shortcuts DO work in Firefox + other webmail editors. So some believe it's a Gmail/Google issue.
  • The shortcuts DO work in other browsers + Gmail. So some to believe it's a Firefox/Mozilla issue.

-Does the webmail's type of text editor matter?

  • Yes. The shortcuts DO work in Firefox + Gmail's plain text editor.
  • This means we should clarify our original issue to read: shortcuts DO NOT work in Firefox + Gmail's rich text editor.

-Wait... Then maybe Gmail has nothing to do with it, and this is more of a Firefox + (any webmail's) rich text editor issue?

-Okay, so the problem is Google's rich text editors?

  • Could be, BUT the shortcuts work fine in Google Docs' rich text editor.
  • HOWEVER (this is where it gets interesting), Google Docs changed their rich text editor in April 2010, and the shortcuts will only work on docs created in the newer editor. (Or if the older docs have been converted into the new editor. Google gives you this option in the doc screen.)
  • So to clarify what I said two bullets ago, the shortcuts work fine in Google Docs' "newest" rich text editor.

-So the problem is in one of Google's old rich text editors, which Gmail currently uses but Google Docs stopped using in April 2010?

  • That's my guess. It seems like Firefox doesn't like something in the code of this older RTE.

-I have a different, yet similar problem... Sometimes the Command + Left Arrow shortcut in Firefox takes me back one page. Is this related?

  • Kind of. The key point to understand here is that the same shortcut can mean different things depending on what part of a browser page your mouse/cursor is focused on. For example, if you enter that shortcut while your cursor is focused in a text editable field (such as composing an email) the browser should move your cursor to the beginning of that line of text -- just like you'd expect in MS Word, TextEdit, etc. But if you enter that shortcut while reading a news page, the browser should load the previous page you were on (which can also be achieved by clicking "Delete.") From what I understand, Firefox has a hard time identifying certain rich text editors, and it takes different actions depending on what it thinks its seeing. For instance, it can't see Hotmail's rich text editor, so if you enter the shortcut while in there it thinks you want to navigate pages and it backs you up to the previous page. In Gmail it can see the rich text editor, but it doesn't know what it is -- so it just does nothing.
  • The good news is that there IS a solution for the Hotmail-related issue: it's an addon called keyconfig that lets you customize certain shortcuts. You can't create new shortcuts with it (therefore it doesn't fix the Gmail-related issue), but it does allow you to disable existing shortcuts. After installing it you just open the tools menu, look for the "goBackKb" shortcut, disable it, restart -- and that turns off the "Command + Left Arrow" navigation shortcut. This not only fixed the Hotmail-related issue for me, but it also solved the issue with some of the other rich text editors. For example, it's not an issue anymore on sites that use the TinyMCE rich text editor (like The keyconfig addon has lots of other uses, many of which you can find in their forums. It's not available in the official addons repository, which makes some people nervous. But there seems to be a lot of community support behind it.


-Source links where I found a lot of this info:

-Bugs related to this that have been reported to Mozilla (if you read these they'll seem promising at first; but by the end they just kinda fizzle out without being fixed):

-And here are some other sites that may be of use:

Now lets cross our fingers and hope that at least one person at Mozilla and one person at Google take an interest  ;-)

[NOTE: If anyone knows of a better place to post this, please let me know. I'm just an ordinary Firefox user, not a developer, and I fully realize that there may be a better place for things like this.]

Modified by gatorfantom

more options

Working workaround: remap Command-Left and Command-Right to Ctrl-A and Ctrl-E respectively. I use Butler ( to do this, which is a bit overpowered for the job, but I use it for other things anyway. As a side note, I've actually remaped Home and End to this pair since, coming from a linux environment, I prefer that behaviour for these keys.


Modified by ugray

more options

Nice work-around using Butler.

However, I really want to highlight to the end of line, and to the beginning of line (i.e. shift-command-right arrow, shift-command-left arrow).

shift-ctrl-a and shift-ctrl-e don't work for highlighting.

more options

Tools > Addons > search for Keyfixer. Maps the keys like Windows. Pressing home / end takes you to the beginning / end of line. Also maps Ctrl + Left/Right arrows to go to the beginning / end of words.

Perhaps ask the developer to allow you to customise the mappings.

Modified by Jayden

more options

Thanks for that complete investigation!

I just wanted to say that with Mac OSX 10.6.8 and Firefox 8 this very unhandy problem still persists.

People form Mozilla, would you comment on this please?

more options

This problem has been marked "solved" but isn't solved at all. This problem still exists, and is infuriating to any Mac/Firefox/Gmail users who like to stick to the keyboard. I've also noticed this happens in other google apps (blogger, docs, etc).

more options

Chosen Solution

Despite being marked as "solved" I'm on Firefox 10.0.1 and this is still a problem. Also wanted to mention a similar key combination command-delete. In any other application this deletes everything between the cursor and the beginning of the current line.