X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox won't play ogg ogv video files

Posted

When I use the video tag in HTML5 or videos the .ogg and .ogv files won't play. I get a grey block with an X in it.

I have looked at other posts on this topic but the replies are altogether too geeky and I cannot understand them. Why do Flash and mp4 play without any problem, exactly as they are supposed to do, but .ogv doesn't?

I convert the video with the Froggy in Firefox thing and then upload it to my server. The .ogv plays in VLC player, so it seems OK, but something happens between creation>upload>download to browser.

I would really appreciate a reply in plain English.

Finally, a plea to the Mozilla team -- why not get with the strength and embrace H264? I've read all your reasons but they don't hold up.

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape
  • Contribute Firefox IBE Plugin DLL
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DNL Reader
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.1 r102
  • iTunes Detector Plug-in
  • DivX Web Player version 2.0.3.4
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.50917.0
  • Office Live Update v1.5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

Question owner

I forgot to mention -- when the video is transcoded [from avi to ogv] in Firefogg the Preview screen also shows a grey rectangle with an X in it. But the ogv file saved to the desktop runs in VLC [ and nothing else]. According to the on-screen info the transcoding is complete and successful -- but no preview!

Help!

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Make sure that the server sends the ogv file with a supported MIME type.

Question owner

1000 thanks for that help. It works beautifully. But I should point out that there is no MIME type in the .htaccess file. I'm not sure if that matters, but I added a type for Theora .ogv .ogg just in case. I then uploaded it to the video directory on my server and the videos now play in Firefox.

SarahSaunders 0 solutions 3 answers

Helpful Reply

Im having the same issue, however, Ive updated the htaccess file with the correct mime types, Every other browser is playing its respective version properly except Firefox. I have the video tag with the following files defined in this order: Mp4, WebM, Ogv, and finally a fallback to a youtube hosted video (which works perfectly in IE7 and 8). Ive tried everything I can think of. Any one have any other solutions to getting the html5 Video to work in Firefox?

One other thing is that the controls even flash for a second then they disappear and I get the gray box with the x. And also, when I drag the .ogv file itself to a firefox browser window, it plays. So the file is working.

Oh one more point to note: its in Firefox across the board - Mac and PC.

Totally baffled...

Modified by SarahSaunders

pjbtwo 0 solutions 1 answers

I'm having the exact same problem as Sarah. I've tried everything. Changed ogv to ogg added type in Apache httpd.conf and nothing works. I can see in Charles that FF i accessing the film a number of times and that the server returns correct mime type. If I type in url directly to movie file FF plays it correct but not when I use video tag. I've encoded the films with ffmpeg using libvorbis as audio codec and libtheora for video. Please please help someone. I'm using FF 3.6.13.

//

Modified by pjbtwo

rocheking 0 solutions 1 answers

ONE SOLUTION... omg, if you select one of the options under custom settings (and why wouldn't you since you have some ogg options there) then you'll get a bad video. If you encode it without touching the dropdown (ie leave it on "custom settings" or if you select "custom settings" then you get an ok outcome. Easily fixed usabiilty flaw (hint hint).

SarahSaunders 0 solutions 3 answers

Oh Dearest rocheking, While I feel that the 'omg' attitude was fairly unnecessary, your solution means nothing to me. That didn't help at all and I think its unfair for you to trivialize our problem.

I am using 'Miro Video Converter' to convert my video. My only option from the dropdown is Theora, thats it. I dont have any other things that could be changed, I can't get a more specific 'version' of Theora or anything.

Second, as both I and pjbtwo said, the video itself is playing fine. So how does that work? Why would the video play fine on its own, both in VLC and Firefox itself, and not when it is placed on the page when the other steps were taken to define the MIME types. Elaboration on that and some explanation on how that works would be helpful instead of assuming we are a bunch of idiots.

Your 'attempt' at a helpful reply was appreciated, but you may want to rethink your responses before you try to make others sound like morons.

SarahSaunders 0 solutions 3 answers

Hey pjbtwo, I never did actually solve the problem. I may try a different converter and attempt to decode rocheking's 'solution'.

What I ended up having to do (because I just needed to get it done) is put in a php sniffer that basically just says, if the user browser is Firefox, then display the YouTube hosted video. Otherwise, if its any other browser, display the video tag and the corresponding videos within it. If I can help you any further just let me know.

desertlavender 0 solutions 2 answers

The problem is Firefox 4. Apparently it's not ogg video compatible. I just reverted to Firefox 3.6 and all my ogg videos play perfectly once again. BTW I have been a faithful Firefox user for years, but 4.0 is the upgrade from Hell. Extremely slow and buggy.

desertlavender 0 solutions 2 answers

Figured it out.

Replace this code: <video controls preload="none">

with this code: <video autobuffer controls preload="auto" >

Plays in Firefox 3.6, Firefox 4.0 and now MSIE 9

Modified by cor-el

ianebden 0 solutions 1 answers

In my case I just needed to set the proper MIME types in my .htaccess file like so:

  • AddType audio/ogg oga ogg
  • AddType video/ogg ogv

All good now in FF4. Not checked in FF3 but assume it was same issue.

Modified by ianebden

bigmass 0 solutions 1 answers

I am in the same boat as SarahSaunders. I tried every fix that has been suggested, but still I can't get the video to play in FF.

I did finally come up with a possible cause, however. When I checked the client's hosting account, I saw that it is a Windows account. Could that be causing the problem? In my understanding, setting MIME types is significantly different for Windows hosting compared to Unix hosting.

Search Engine Domination 0 solutions 1 answers

Helpful Reply

Adding the sample file above did nothing for me. Changing the index.html code (controls) above didn't really do much either but...

FTPing into the account and editing the ".htaccess" file that already existed by adding the following:

AddType audio/ogg oga ogg
AddType video/ogg ogv

Worked wonders! I can now play html5 video from my home page

Modified by cor-el

jlee614 0 solutions 1 answers

Try this: (1) Update/add the .htaccess file in your directory (just copy the code from: https://developer.mozilla.org/en/Sample_.htaccess_file)

(2) After that, add the following two lines to the .htaccess file: AddType audio/ogg oga ogg AddType video/ogg ogv

This worked for me. Hopefully it will work for others too.

anawaz 0 solutions 1 answers

OK whilst adding the MIME types to the htaccess file does solve the problem for other browsers, it doesn't resolve the issue with FireFox.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You may have to reload pages and bypass the cache or use Clear Recent History to clear the browsing cache from the last hour.

Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)
daneb 0 solutions 1 answers

I've tried adding the MIME type to .htaccess to no avail. We have several sites on this server and thus several .htaccess files. I edited the file via terminal (nano /directory/.htaccess) and though the file didn't show up in a directory listing, when I nano'd into it, there was already info there. I added the MIME type, restarted Apache, but the video still wouldn't load. It works in EVERY other major browser now, just not FF. Ideas?

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You can check which MIME type the server sends by opening the file in Firefox via the location bar and go to "Tools > Page Info > General" or via a site like web-sniffer.net

Make sure that you only do a HEAD request and not download that full file via a GET.

Modified by cor-el

dan2600 0 solutions 1 answers

The .htaccess fix worked for me...weird that I had to do that, all other browsers (including firefox 3) were working fine without the change.

cestmoi 0 solutions 3 answers

Indeed... a few guys above who mentioned .htaccess were right...


after encountering the same problem with the combination of html5 and its very useful 'audio' tag and 'ogg' audio files and Firefox-3623 on XP and Mac... (was looking for an alternate for Firefox to .wav or .swf/mp3 etc. in search of the most simplistic cross browser offer for sound; didn't test video this time though)

I did some successful and lab-type (but very limited) testing with various browsers and servers, I found that this problem is the logical but wrong combination of

(i) some web servers [incomplete lists of mime types, either in .htaccess files or on my own Apache mac servers some alternate config files,  httpd.conf or mime.types or magic files directly, all concerning the ogg mime type in their long lists of these file types -browsers are not always too intelligent, so servers have to offer these lists telling what to do with each type of file-], ...hence in particular on Apache servers then] and 

(ii) the 2 browser versions of Firefox I was using for testing, on 2 client systems, Firefox 3623 -on both Macppc1058 & XP (rather curiously by chance it was the exact same version number)-; ...apparently both too rigid/norm-abiding in their sniffing of these file mime types, contrarily for ex. to XP-Chrome14 for ex. which I tested also, and had no problem at all with ogg files for the same html code)...

I also checked the official IANA reference file of mime types/extensions at: http://www.iana.org/assignments/media-types/ (this address is given with the top comment of the mime.types file in ma Apache server) So I noticed that 3 Apache servers across the globe that I am using had these same incomplete mime type lists concerning ogg files, only : (type/sub-type .extension)

application/ogg   .ogg

and had not at all what should be the correct complements (to be copied as well in these servers' files), at least: audio/ogg .oga video/ogg .ogv (one can add several extensions to each type in these long lists on servers' configuration files, I just put the official main ones here; one may even add to the type/sub-type the name of codecs, etc. etc.)

conclusion: for ogg files, on the server side, as long as one may fix the server(s), it's ok, otherwise there is no fix on the client side with just html, etc. if the clients have, unhappily, the wrong version of Firefox, for these cases, fallback required (question then, for a server, is it really worth bothering with ogg files at all ? ...the little ogg tribes may thank Firefox for killing them all at once with this lost bullet !)