X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

A non-administrator is unable to launch Firefox

Posted

Firefox will only run if launched as an administrator, through the administrator's account or by launching "run as administrator", thus requiring an administrative password. Otherwise, double-clicking the icon results in no apparent action.

I have completely uninstalled the application, removed the program folder, and reinstalled but the problem remains. I do not have the same problem with other applications.

Can Firefox be configured so that it does not require administrative-level permission to run?

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Default Plug-in
  • Shockwave Flash 10.0 r42
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • 4.0.50917.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Google Update
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

Application Basics
Name
Firefox
Version
3.6.12
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
ForceField Toolbar
1.5.152.10
true
{FFB96CC1-7EB3-449D-B827-DB661701C6BB}
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:1.9.2.12
extensions.lastAppVersion
3.6.12
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Check that you do not run Firefox as Administrator.
Right-click the Firefox desktop shortcut and choose "Properties".
In the Compatibility tab, make sure that Privilege Level: "Run this program as Administrator" is not selected.
You also need to check the Properties of the firefox.exe program in the Firefox program directory.

Did you check your security software (firewall)?

A possible cause is security software (firewall) that blocks or restricts Firefox without informing you about that, possibly after detecting changes (update) to the Firefox program.
Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process.
See Server Not Found - Troubleshoot connection problems and Configure firewalls so that Firefox can access the Internet and http://kb.mozillazine.org/Firewalls

Question owner

Thanks for replying.

I had already checked the privilege assignments.

At your suggestion, I logged back in as the administrator and completely removed all mention of FF from ZoneAlarm. This did not help.

I'm fairly close to throwing in the towel here.

jpl 0 solutions 1 answers

Helpful Reply

I am having the exact same problem, though only with one user on the account. I am running Windows Vista Home Premium 32 bit. I started having problems with this about a month ago after Firefox updated. I have two users on my account - an administrator and a standard account. The administrator account requires the use of a password to run Firefox due to Windows User Account Control, the standard account does not. I've checked all the privilege assignments and uninstalled and reinstalled Firefox.

mars1412 0 solutions 1 answers

in my case the firefox profile was broken

I started firefox with the -P option, created a new profile and it worked again. see also: Standard diagnostic - Firefox

BodyworkeR 0 solutions 1 answers

I'm running Firefox 7.01 on an XP machine and a Vista machine. It works with minor problems on XP but like the posts above, only when run as administrator on Vista. FWIW I had to run the install program as admin on my Vista machine even tho I'd logged on to an administrator account. The install program would hang until I ran it as admin.