X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Need to really, actually disable all cache

Posted

I've been hopelessly wandering the world-wide web trying to figure out how to really, actually disable cache in Firefox. I've found a lot of solutions that don't actually, really do anything at all. Most answers explain how to delete the cache, but I need to disable it, not delete it, for all types of content, whether images, HTML, CSS, name it. All of it, always, every time, without exceptions.

The particular problem I have now is that my CSS (hosted on localhost:82) always gets remembered for some reason. I need to reload about 3-5 times before Firefox actually bothers to read the CSS file again. I need it read every single time. I've got plenty of bandwidth running to 127.0.0.1 and I do not need cache; much rather I need to know what the changes I make to my website look like.

Here are my about:config items that I've configured already:

browser.cache.disk.enable = FALSE

browser.cache.disk_cache_ssl = FALSE

browser.cache.memory.enable = FALSE

browser.cache.offline.capacity = 0

browser.cache.offline.enable = FALSE

media.cache_size = 0

network.http.use-cache = FALSE

I really don't know how to be clearer; I actually, really want the cache off. Firefox doesn't seem to understand this.

Any help deeply appreciated.

Modified by Teekin

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 10.1 r85
  • 4.0.50917.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 (.NET CLR 3.5.30729)

More Information

browser.cache.disk.enable = FALSE
browser.cache.disk_cache_ssl = FALSE
browser.cache.memory.enable = FALSE
browser.cache.offline.capacity = 0
browser.cache.offline.enable = FALSE
media.cache_size = 0
network.http.use-cache = FALSE

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97023 answers

You can reload the page and bypass the cache with:

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

See Keyboard shortcuts - Perform common Firefox tasks quickly and Use mouse shortcuts to perform common tasks in Firefox

Firefox also has a memory cache, but disabling the memory cache isn't recommended and can cause problems.

If you run in Private Browsing - Browse the web without saving information about the sites you visit mode then also the disk cache is disabled but also other features like permanent cookies and history are disabled.

Helpful Reply

Thank you for your response.

I'm on Windows, and none of the suggested methods work. I've been trying those since day 1, but it's always the same story, taking somewhere between 3-5 clicks to re-read the CSS.

I fail to see why in the world it would cause problems to disable the cache entirely. It's a pretty serious design flaw if Firefox is made in such a way that it depends on using cache at seemingly arbitrary times. I would have imagined that turning it off would have the exact same programmatic consequence as using Ctrl-Shift-R'ing or Ctrl-F5'ing by default... that is to say if they actually worked, which they don't.

As for disabling the memory cache, you mention that it's possible but you don't mention how to go about doing it. Furthermore I don't really mind if it causes problems (although I'd like to know which problems) because I already have a serious problem; the problem that I can't turn off the cache and therefore have to literally guess what impact my CSS changes have on the website.

This is such an important point that I wonder how the Firefox/Chrome crowd ever expected web developers to do their work. It has happened numerous times now that I make some change, hit Ctrl-F5/Ctrl-Shift-R (even 2-3 times) and everything is fine so I continue with my next change, only to discover that my earlier change actually messed things up but the browser lied to me about it.

Am I the only one who considers the difficulty of doing this absolutely appalling? Web developers NEED to be able to trust their browsers to disable the content that they're working with. It is not a matter of luxury, it's pretty elementary, actually.

Thanks for taking the time to respond but unfortunately it wasn't very helpful.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97023 answers

You already have both the memory (browser.cache.memory.enable: false) and disk cache (browser.cache.disk.enable: false) disabled. If that isn't sufficient and it still doesn't work if you bypass the cache with Ctrl+F5 then it sounds that the files are cache elsewhere (router with a cache or maybe your ISP).

Question owner

I'll take a look at that and report back here, thanks.

firenav 0 solutions 1 answers

Helpful Reply

Hai mate...

I add Here’s how to disable FireFox’s browser cache completely.

Fire up FireFox

Type about:config in your address bar

Type ‘cache’ in the search bar, and look for network.http.use-cache, and double click it to set it to false. Double clicking it again will set it to true and re-enable the cache …and then you’re done.

To forcibly reload a page and all its dependencies, direct from source, ignoring local and proxy caches hold the shift key and hit reload.

This applies not only to FireFox but also IE6/7 and Safari (maybe others too). I have a feeling this may be a ratified standard.

I think it may use for you.........