X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Disable "this connection is untrusted" page

Posted

I would like to completely disable the "this connection is untrusted dialog." I am an administrator and deal with many intranet sites. It is not cost effective to set an exception for each site. Corporate standards require us to use either IE, or Firefox, and I would prefer not to have to use IE.

To be clear: I am not looking for a solution that lessens the amount of overall clicks, like in browser.ssl override behavor in "about:config" nor am I looking for an Add-on (like "remember certificate exception"). I am looking for a way to remove the "this connection is untrusted" dialog completely.

Chosen solution

Skip Cert Error

"This Firefox extension enables skipping the SSL/TLS certificate error page, for specific configurable conditions, like self-signed cert or unknown issuer, by adding a temporary exception."

Read this answer in context 23

Additional System Details

Installed Plug-ins

  • IE Tab Plug-in for Mozilla/Firefox
  • ActiveTouch General Plugin Container Version 105
  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.50524.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

More Information

Modified about:config for the browser.ssl override behavor
Tried various add-ons

zippity 0 solutions 1 answers

seems some are not reading this correctly.. I also want to remove or reconfigure Firefox default reaction to a certificate with no 'paid' root CA installed .. as do many people who use self-signed certificates .. this is NOT a Firefox fault and has nothing to do with times/dates etc..  :) There maybe should be a 'network, or 'professional' section to the forums where people who need to get results that are not required for normal browsing can ask questions without having all the misunderstandings..

Vivek 310 solutions 2084 answers

Hi zippity,

You may want to try Convergence which is based on Perspectives.

Details

Slashdot

Perspectives Project

miker417 0 solutions 1 answers

Outstanding solution! Thank you very much. My problem was that if tried to Add Exception to the main "This connection is not trusted" message, the Add Security Exception dialog box said the certificate was valid(!?), and the Confirm Security Exception button was disabled. Catch 22! I could never get to the web page no matter what I did. See attached screenshots.

dirose76 0 solutions 1 answers

Try turning off the privacy feature, "Warn me when sites try to install addons." I've been having this issue too but as soon as I turned off that feature it stopped. Still doesn't solve the "invalid URL" issue with my Facebook games but it's a start...hth

Adam Muntner 0 solutions 1 answers

Just wanting to add a couple comments to this conversation, for posterity.

In reply to the comment, "I appreciate the reply, but unfortunately that wouldn't work. The goal is to reduce the amount of administration time needed for each site. Installing certs and keeping them current for each of these sites/devices would cause much more effort than simply adding an exemption. "

You'd only have to install the certificate of the common parent CA which issued/signed their certs.

A security warning regarding a blanked policy of browsers hiding warnings of certificate failures:

Disabling warnings for *all* self-signed certificates for browsers which can reach the Internet is not a good idea.

Users will have no idea if Internet sites they are connecting to are via a valid certificate, or if their connection is being mirrored by a 3rd party. Their banking, email, and other personal banking info can be exposed.

babyArmalite 0 solutions 1 answers

just check your TIME, DATE or TIMEZONE. when all is ok its work fine

Question owner

The problem is browser, not browsers. I'm talking about disabling that "feature" for just myself or other sys admins who want to disable the issue once on the browser, instead of dealing with say, ILO's for hundreds of servers, or temporary websites that developers may put up and tear down quickly. I am not suggesting disabling it for users at large, but just giving us the choice to disable it ourselves on our own browser.

iFoundOUTHOW 0 solutions 1 answers

I found out the problem for me was that in the lower right hand corner of your desktop is the time and date. MAKE SURE YOUR DATE IS CORRECT! or else all windows account will have the same problem with untrusted connections.

To correct this, double click on the time and manually correct the date yourself

Modified by iFoundOUTHOW

Noah_SUMO
  • Moderator
50 solutions 303 answers

Notice from moderator
This thread has already been solved for the owner by Gingerbread_Man's post.

Other helpful posts you can check out:

This thread is being locked due to its large size which is making it hard & confusing to give support to specific individual users. So to avoid a unorganized situation like this, it helps us give you one-on-one support if you post in a thread of your own.

To start a new thread, use this link: https://support.mozilla.org/en-US/questions/new

The main reason we ask people to do that, is that a new thread will auto detect info about your system like your OS, Firefox version and Plugins. That way we can look and see if anything stands out. Also make sure you fill out the Troubleshooting Information section by going to Help > Troubleshooting Information in Firefox and copying and pasting that info there using the "Copy to clipboard" button. It'll help us see what add-ons (which are different from plugins) you have and if we see you have one we know is a troublemaker we can tell you really quick.

Modified by Noah_SUMO