Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows security confirmation window pops up every time I try to start firefox

  • 2 replies
  • 5 have this problem
  • 2 views
  • Last reply by AaronStarr

more options

When I click on my firefox shortcut, a security window pops up asking if I trust firefox to make changes to my computer. At first I though it was because of an update but it asks for security confirmation every time I open a window. There's no "add exception" or "don't ask me again button, and the only option it the security window offers is an option to change the harshness of my security settings, which is not recommended.

When I click on my firefox shortcut, a security window pops up asking if I trust firefox to make changes to my computer. At first I though it was because of an update but it asks for security confirmation every time I open a window. There's no "add exception" or "don't ask me again button, and the only option it the security window offers is an option to change the harshness of my security settings, which is not recommended.

All Replies (2)

more options

Check that you do not run Firefox as Administrator.

Right-click the Firefox desktop shortcut and choose "Properties".

In the Compatibility tab, make sure that Privilege Level: "Run this program as Administrator" is not selected.

You also need to check the Properties of the firefox.exe program in the Firefox program directory.

more options

Thanks a ton, I did what you said and it's fine now