X
Tap here to go to the mobile version of the site.

Support Forum

Why won't Firefox show visited links in a different color, even though I've specified so in my Color Settings?

Posted

When I'm on a page with multiple links (ie. Google Search, Craig's List, etc), and I click on a link, then return to the search page, Firefox doesn't show the visited links in purple. As a result I can't see which links I've visited, which makes browsing very difficult on some sites. I've updated my Color Settings to show visited links in purple, but it's not applying. What might be causing this?

When I'm on a page with multiple links (ie. Google Search, Craig's List, etc), and I click on a link, then return to the search page, Firefox doesn't show the visited links in purple. As a result I can't see which links I've visited, which makes browsing very difficult on some sites. I've updated my Color Settings to show visited links in purple, but it's not applying. What might be causing this?

Additional System Details

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Gecko default plugin
  • npmnqmp 071503000004
  • iPhoto6
  • Office Live Update v1.0
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.0 r45

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12331 solutions 114053 answers

Make sure that you not run Firefox in (permanent) Private Browsing - Use Firefox without saving history mode

  • You enter Private Browsing mode if you select: Firefox > Preferences > Privacy > History: Firefox will: "Never Remember History"
  • To see all History settings, choose: Firefox > Preferences > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Automatically start Firefox in a private browsing session"
Make sure that you not run Firefox in (permanent) [[Private Browsing]] mode * You enter Private Browsing mode if you select: Firefox > Preferences > Privacy > History: Firefox will: "Never Remember History" * To see all History settings, choose: Firefox > Preferences > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Uncheck: [ ] "Automatically start Firefox in a private browsing session"
WilVan 0 solutions 1 answers

Hi,

I try a few other options apart from this one and none worked, till finally I try the below.

Tools -> Options -> Content (tab) -> Colors-> disable this flag.

"Allow pages to choose their own colors, instead of my selection above"

Hi, I try a few other options apart from this one and none worked, till finally I try the below. Tools -> Options -> Content (tab) -> Colors-> disable this flag. "Allow pages to choose their own colors, instead of my selection above"
toontyke 0 solutions 1 answers

I had this problem and it was driving me mad. I have just un-ticked the option that lets pages choose their own colour for links. I then viewed some pages in the default electric-blue and purple and realised that was a price not worth paying. I went back to preferences and re-ticked the option that lets pages choose their own colour for links. I also selected a slightly different, lighter colour purple for the visited links and went back to browsing.

To my delight the browser now behaves correctly! Don't know which bit of what I did sorted it but there you go. Maybe someone else will try this an confirm that it works?

I had this problem and it was driving me mad. I have just un-ticked the option that lets pages choose their own colour for links. I then viewed some pages in the default electric-blue and purple and realised that was a price not worth paying. I went back to preferences and re-ticked the option that lets pages choose their own colour for links. I also selected a slightly different, lighter colour purple for the visited links and went back to browsing. To my delight the browser now behaves correctly! Don't know which bit of what I did sorted it but there you go. Maybe someone else will try this an confirm that it works?
cor-el
  • Top 10 Contributor
  • Moderator
12331 solutions 114053 answers

There can be more that one cause for not seeing visited link colors.
Firefox even has a pref layout.css.visited_links_enabled on the about:config to suppress the visited link color if set to false. That is to prevent websites from detecting if you have visited specific domains.

If you disable "Allow pages to choose their own colors, instead of my selection above" then you also suppress background images (it is an accessibility feature) and that may not work well on some website that use background images for buttons and links.

There can be more that one cause for not seeing visited link colors.<br /> Firefox even has a pref layout.css.visited_links_enabled on the about:config to suppress the visited link color if set to false. That is to prevent websites from detecting if you have visited specific domains. If you disable "Allow pages to choose their own colors, instead of my selection above" then you also suppress background images (it is an accessibility feature) and that may not work well on some website that use background images for buttons and links.

Helpful Reply

I think I figured it out. My privacy settings were set as "Custom," so I chose "Remember History." Now the link colors seem to be working.

Thank you!

I think I figured it out. My privacy settings were set as "Custom," so I chose "Remember History." Now the link colors seem to be working. Thank you!
prox04 0 solutions 2 answers

Helpful Reply

Hi at all, I have delete all cookies in Tools -> Options -> Privacy (tab) -> remove individual cookies -> Remove All Cookies

or you make a new profile (on the desktop Windows Logo+R -> firefox.exe -ProfileManager)

and it should work

Hi at all, I have delete all cookies in Tools -> Options -> Privacy (tab) -> remove individual cookies -> Remove All Cookies or you make a new profile (on the desktop Windows Logo+R -> firefox.exe -ProfileManager) and it should work

Modified by prox04

toutou2080 0 solutions 1 answers

Hi You go to tools ->options ->privacy-> chechk conserve history (90 days), and you turn 90 to 0 day. The problem would be solved Good luck!!

Hi You go to tools ->options ->privacy-> chechk conserve history (90 days), and you turn 90 to 0 day. The problem would be solved Good luck!!