X
Tap here to go to the mobile version of the site.

Support Forum

When I click on a hyperlink, how do I keep the Firefox Bookmarks sidebar from automatically opening on new page? (Note: on original page, View/Sidebar/Bookmarks is unchecked)

Posted

Bookmarks sidebar always opens automatically in new page. If I click View/Sidebar/Bookmarks...I can uncheck Bookmarks, but that defeats the purpose of not having it open in the first place.

Is there a separate Firefox setting that controls this function?

Bookmarks sidebar always opens automatically in new page. If I click View/Sidebar/Bookmarks...I can uncheck Bookmarks, but that defeats the purpose of not having it open in the first place. Is there a separate Firefox setting that controls this function?

Additional System Details

Installed Plug-ins

  • getplusplusadobe16249
  • IE Tab Plug-in for Mozilla/Firefox
  • Abacast Netscape Plugin
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 2.0.0048.0
  • 1.9.0009.1
  • np-mswmp
  • Shockwave Flash 10.0 r42
  • iTunes Detector Plug-in
  • Google Updater pluginhttp://pack.google.com/
  • Version 0.8.6f, copyright 1996-2007 The VideoLAN Teamhttp://www.videolan.org/
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.13) Gecko/20100914 Firefox/3.5.13

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40240 answers

Helpful Reply

Assuming that you are opening a bookmark, right-click that bookmark and select Properties, then un-check the preference for Load this bookmark in the sidebar, and then click Save.

Using JavaScript buttons on web pages for "Bookmark this Page" causes that preference to be selected when saving the bookmark in that manner. So, don't use those buttons, use the "Bookmark this Page" feature that is built into Firefox instead.

Assuming that you are opening a bookmark, right-click that bookmark and select '''Properties''', then un-check the preference for '''''Load this bookmark in the sidebar''''', and then click Save. Using JavaScript buttons on web pages for "Bookmark this Page" causes that preference to be selected when saving the bookmark in that manner. So, don't use those buttons, use the "Bookmark this Page" feature that is built into Firefox instead.

Question owner

Let me reword this.

I am not opening a bookmark or bookmarking a page, or doing anything remotely related to Bookmarks. All I am doing is reading webpage A, and then clicking on a hyperlink on webpage A. Then, when linked webpage B opens, webpage B displays the Firefox Bookmarks as a left/vertical sidebar.

I neither need nor want the Bookmarks sidebar (on webpage B). If I click on View/Sidebar/Bookmarks of webpage B, there is a checkmark present (Note: I did nothing to put that checkmark there in the first place.) If I "uncheck" /Bookmarks, the sidebar disappears. However, I do not want to have to "uncheck" /Bookmarks ... just as I do not want to have to click the X on the sidebar to remove it. This is the extra step I now have to do.

What is causing the Bookmarks sidebar to 'automatically' appear on webpage B? Is there a Firefox setting (or Windows XP setting) that will override and prevent sidebars from opening automatically on a hyperlinked webpage?

(Note also that on webpage A, prior to clicking the hyperlink, I clicked on View/Sidebar/Bookmarks and there was no checkmark next to /Bookmarks)

Thanks

MB

Let me reword this. I am not opening a bookmark or bookmarking a page, or doing anything remotely related to Bookmarks. All I am doing is reading webpage A, and then clicking on a hyperlink on webpage A. Then, when linked webpage B opens, webpage B displays the Firefox Bookmarks as a left/vertical sidebar. I neither need nor want the Bookmarks sidebar (on webpage B). If I click on View/Sidebar/Bookmarks of webpage B, there is a checkmark present (Note: I did nothing to put that checkmark there in the first place.) If I "uncheck" /Bookmarks, the sidebar disappears. However, I do not want to have to "uncheck" /Bookmarks ... just as I do not want to have to click the X on the sidebar to remove it. This is the extra step I now have to do. What is causing the Bookmarks sidebar to 'automatically' appear on webpage B? Is there a Firefox setting (or Windows XP setting) that will override and prevent sidebars from opening automatically on a hyperlinked webpage? (Note also that on webpage A, prior to clicking the hyperlink, I clicked on View/Sidebar/Bookmarks and there was no checkmark next to /Bookmarks) Thanks MB
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158573 answers
Can be caused by http://kb.mozillazine.org/Corrupt_localstore.rdf