X
Tap here to go to the mobile version of the site.

Support Forum

Why does new TAB default to Yahoo SEARCH engine page?

Posted

Every time I open a new tab it defaults to Yahoo search engine page. I hate this. I want a BLANK page as in earlier versions of firefox, or I want ability to customize tab (set website of my choice). How can I remove Yahoo from being the default page when I open a new TAB, and set my default tab website of choice.

Does yahoo own Firefox? If so I will install another browser all together.

Every time I open a new tab it defaults to Yahoo search engine page. I hate this. I want a BLANK page as in earlier versions of firefox, or I want ability to customize tab (set website of my choice). How can I remove Yahoo from being the default page when I open a new TAB, and set my default tab website of choice. Does yahoo own Firefox? If so I will install another browser all together.

Chosen solution

it was very helpful,thanks a lot

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • nphpclipbook
  • getplusplusadobe16291
  • ActiveTouch General Plugin Container Version 105
  • np-mswmp
  • npdnu
  • npdnupdater2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.50917.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

More Information

TonyE
  • Moderator
1034 solutions 8840 answers

This is likely to have been modified by an add-on, the built-on option for Firefox will only use a blank page. Check the settings for your add-ons to see if one has such a setting. You can also follow the procedure in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to identify the culprit.

This is likely to have been modified by an add-on, the built-on option for Firefox will only use a blank page. Check the settings for your add-ons to see if one has such a setting. You can also follow the procedure in the [[troubleshooting extensions and themes]] article to identify the culprit.
akron99 0 solutions 1 answers

Helpful Reply

I had the same problem. I found the solution in this article:

http://medicine-opera.com/2010/03/how-to-disable-yahoos-theft-of-firefoxs-open-a-new-tab/

Hope this helps.

I had the same problem. I found the solution in this article: http://medicine-opera.com/2010/03/how-to-disable-yahoos-theft-of-firefoxs-open-a-new-tab/ Hope this helps.
FlipFlops2001 0 solutions 4 answers

Helpful Reply

Here’s the easy, get rid of it for good fix: It’s done within Firefox. Enter [about:config] in the url address box. Click “I’ll be careful. I promise”. In the <filter> field, type “extensions.netassistant” (no quotes). Right click on the field: “extensions.netassistant.tabsearch.url”, click on , either delete its string or enter your own. I’ve entered “https://encrypted.google.com” (this is a beta encrypted search by Google) just as a personal satisfaction against Yahoo. Do the same for:”extensions.netassistant.url” field. NOTE: If you haven’t modified your Firefox configuration before and you don’t feel comfortable in what you are about to do, do a backup of your preferences. The backup procedure can be found at: http://support.mozilla.com/en-US/kb/backing%20up%20your%20information. Or just do a Google search for “backup Firefox pref.js”.

UPDATE:(2/26/2011 5:04PM CST) After all that tinkering with [about:config], (which did work for me), I've found an even simpler answer: -Close all browsers. -Open [control panel]. -Open [add/remove programs] -Remove "net assistant for Firefox" (may be called: "net assistant for Mozilla") -That's it. Restart Firefox and see if it worked.

Here’s the easy, get rid of it for good fix: It’s done within Firefox. Enter [about:config] in the url address box. Click “I’ll be careful. I promise”. In the <filter> field, type “extensions.netassistant” (no quotes). Right click on the field: “extensions.netassistant.tabsearch.url”, click on , either delete its string or enter your own. I’ve entered “https://encrypted.google.com” (this is a beta encrypted search by Google) just as a personal satisfaction against Yahoo. Do the same for:”extensions.netassistant.url” field. '''NOTE''': If you haven’t modified your Firefox configuration before and you don’t feel comfortable in what you are about to do, do a backup of your preferences. The backup procedure can be found at: http://support.mozilla.com/en-US/kb/backing%20up%20your%20information. Or just do a Google search for “backup Firefox pref.js”. '''UPDATE:'''(2/26/2011 5:04PM CST) After all that tinkering with [about:config], (which did work for me), I've found an even simpler answer: -Close all browsers. -Open [control panel]. -Open [add/remove programs] -Remove "net assistant for Firefox" (may be called: "net assistant for Mozilla") -That's it. Restart Firefox and see if it worked.

Modified by FlipFlops2001

Bodacious 0 solutions 1 answers

Thanks FlipFlops2001! I used the update/simple fix, and it worked perfect!!

Thanks FlipFlops2001! I used the update/simple fix, and it worked perfect!!
mahmoudmourad9 1 solutions 3 answers

Chosen Solution

it was very helpful,thanks a lot

it was very helpful,thanks a lot