X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Keyword search not working from address bar

Posted

Hello,

The problem is actually explained in the title. However, I'll repeat it with some modification.

When I type something in my address bar, I'm expecting to be redirected to Google search results, if entered string isn't an actual web address. That's what I'm used to for quite some time in FF now. As opposed, when I now enter something in address bar, I get this opened: http://something/ Obviously, not something that's much appreciated.

Please check this link before you direct me to set keyword search via about:config, because I think that this is the way it was before, while everything was working.

(link: http://img543.imageshack.us/img543/9561/9122010101528am.png)

Thank you, Dan

Chosen solution

See http://kb.mozillazine.org/Location_Bar_search
Check the pref keyword.URL on the about:config page: http://kb.mozillazine.org/Keyword%2eURL

See also http://kb.mozillazine.org/keyword.enabled

You can also check the browser.fixup.* prefs on the about:config page and make sure that they have the default value.
See http://kb.mozillazine.org/about%3Aconfig

Read this answer in context 7

Additional System Details

This happened

Every time Firefox opened

This started when...

Not sure. I updated to FF 3.6.9. yesterday, but can't be sure it's a result of the update.

Installed Plug-ins

  • Version 1.3.1.0
  • Google Talk Plugin Video Accelerator version:0.1.43.2
  • Winamp Application Detector
  • Foxit Reader Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.1 r82
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.50826.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96806 answers

Chosen Solution

See http://kb.mozillazine.org/Location_Bar_search
Check the pref keyword.URL on the about:config page: http://kb.mozillazine.org/Keyword%2eURL

See also http://kb.mozillazine.org/keyword.enabled

You can also check the browser.fixup.* prefs on the about:config page and make sure that they have the default value.
See http://kb.mozillazine.org/about%3Aconfig

Question owner

Thank you for your reply. Turned out that "http://kb.mozillazine.org/Keyword.URL" article was a winner. When I posted this question, I actually WAS behind a proxy server, at my University, and it turned out that proxy was trying to resolve entered word as address for me. Unfortunately, proxy server is not as smart as mozilla firefox ;)

Best, Dan

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96806 answers

You're welcome

ssj300 0 solutions 1 answers

1 word searches get forwarded to my service provider search engine, is there a fix for that?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96806 answers

Sounds that you have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.
You can also check if there is a link on the search results page to go to your ISP and opt-out.